Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Probleem met bestandsdelen nà upgrade naar Ub.16.04  (gelezen 1603 keer)

Offline Strandkruier

  • Lid
    • Mijn (eenvoudige) website
  • Steunpunt: Nee
Probleem met bestandsdelen nà upgrade naar Ub.16.04
« Gepost op: 2017/02/25, 20:01:53 »
Dag, iedereen,

Ik heb thuis 4 pc's in een klein netwerk staan.. Twee daarvan zijn W10-pc's en de twee andere zijn upgrades naar Ubuntu 16.04. Ik gebruik zelf slechts 3 van die pc's. Eén W10-pc is niet van mij.
Ik heb eigenlijk geen moeilijkheden om in die drie overblijvende pc's onderling om bestanden te delen. Het gaat heel vlot, zonder moeilijkheden, tussen mijn Ubuntu-pc's maar met één van die pc's kan ik niet tot bij de gewenste locaties geraken op mijn W10-pc. Met de andere wel. Ik werk met de netwerkadressen van de mappen die ik wil benaderen. Nu blijft dus voor één Ubuntu-pc de deur gesloten tot de W10-pc. Anoniem inloggen gaat niet en er wordt bij geregistreerd inloggen steeds om een wachtwoord gevraagd. Met de andere Ubuntu-pc, die onder dezelfde versie draait, lukt het dus wel om de W10-pc te benaderen.
Dus: waarom heeft de ene pc een wachtwoord nodig om naar W10 te gaan en de andere niet? Wààr moet ik het gaan zoeken?

Met vriendelijke groeten,


Norbert

Offline youpie123

  • Lid
  • Steunpunt: Ja
Re: Probleem met bestandsdelen nà upgrade naar Ub.16.04
« Reactie #1 Gepost op: 2017/02/25, 23:00:10 »
Als ik het goed begrijp is dit gekomen na upgraden naar 16.04 op de beide Ubuntu machines? Dus voorheen werkte het wel van beide Ubuntu computers op de W10 computer te komen?

Omdat je ene Ubuntu PC wel verbinding met W10 kan maken ga ik er vanuit dat Windows goed is geconfigureerd betreffende Samba. De andere Ubuntu PC kan W10 wel benaderen maar krijgt geen toegang dus is het netwerk in orde. Het gaat om een configuratiefoutje, maar waar?  ;)
Ik zou om te beginnen de smb.conf bestanden van de 2 Ubuntu computers eens te vergelijken. Zitten daar verschillen in en welke verschillen. Is bijvoorbeeld de naam van de werkgroep op alle computers hetzelfde etc?

De smb.conf vind je onder /etc/samba/
Groeten, Joep
Ubuntu Mate 16.04.2 op een Intel XEON 3460 Server

Offline Strandkruier

  • Lid
    • Mijn (eenvoudige) website
  • Steunpunt: Nee
Re: Probleem met bestandsdelen nà upgrade naar Ub.16.04
« Reactie #2 Gepost op: 2017/02/26, 09:08:22 »
Ik  heb daar ook al aan gedacht, Youpie123. Er zitten inderdaad verschillen tussen beide smb.confs. Dus, ik zou gewoon een kopie kunnen nemen van de smb.conf, zoals die op de Ubuntu-pc staat waar communiceren wèl lukt en die gewoon over de smb.conf schrijven in de Ubuntu-pc waar het niet gaat? Vanzelfsprekend wel een back-up nemen.. Ik stond op het punt om het gisteren te doen maar ik dacht: ik ga het eerst vragen!

Norbert

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Probleem met bestandsdelen nà upgrade naar Ub.16.04
« Reactie #3 Gepost op: 2017/02/26, 09:46:16 »
Als bij de andere pc's wel alles werkt, dan ligt het aan windows.

Offline Strandkruier

  • Lid
    • Mijn (eenvoudige) website
  • Steunpunt: Nee
Re: Probleem met bestandsdelen nà upgrade naar Ub.16.04
« Reactie #4 Gepost op: 2017/02/26, 10:32:03 »
Tja, kijk, dàt was ook mijn eerste gedacht, jan11000. Maar, wat moet ik dan in die W10 wijzigen, hé?

Norbert

Offline youpie123

  • Lid
  • Steunpunt: Ja
Re: Probleem met bestandsdelen nà upgrade naar Ub.16.04
« Reactie #5 Gepost op: 2017/02/26, 12:46:47 »
Als bij de andere pc's wel alles werkt, dan ligt het aan windows.
Lijkt me niet omdat de éne Ubuntu PC wel gewoon verbinding maakt en de andere niet. Maar je hebt me wel aan het denken gezet Jan. Misschien is er een gevecht bezig tussen de PCś. Ze willen misschien allemaal Masterbrowser worden....

Als ik in mijn log kijk (var/log/samba/log.nmdb) dan zie ik dat de PC waar ik op werk Masterbrowser is:
Samba name server SRV1 is now a local master browser for workgroup WORKGROUP on subnet xxx.xxx.x.xx
Ik heb echter hier geen concurrentie van een W10 PC die misschien ook masterbrowser is of wil zijn... Hoe je dit in Windows kan zien weet ik niet meer helaas maar in smb.conf kan je die regel misschien op nee zetten.
local master = no in het global gedeelte van smb.conf
Groeten, Joep
Ubuntu Mate 16.04.2 op een Intel XEON 3460 Server

Offline Strandkruier

  • Lid
    • Mijn (eenvoudige) website
  • Steunpunt: Nee
Re: Probleem met bestandsdelen nà upgrade naar Ub.16.04
« Reactie #6 Gepost op: 2017/02/27, 13:23:02 »
Dag iedereen,

Ik heb het kunnen oplossen! Ik heb eerst eens met "sudo apt-get install samba" in de terminal opnieuw samba geïnstalleerd. Dat was eigenlijk niet nodig want er kwam een melding dat het er al stond. Wel werden een hele hoop andere, overbodig geworden zaken verwijderd. Nazicht van smb.conf leerde mij dat deze van inhoud niets gewijzigd was t.o.v. deze die er al stond.
De clou lag hem in het inloggen via Nautilus. Daar kun je in het scherm, aan de linkerzijde, "Met de server verbinden."  Als ik daar op klikte kwam er een venstertje tevoorschijn, "Verbinden met de server" genaamd en dààr moest ik ingeven: smb://norbert2/ (norbert2 is de naam van mijn W10-pc in mijn netwerk en dit was al eerder ingesteld). Maar als je dàt doet komt er een (ander) venstertje tevoorschijn waarin gevraagd wordt in te loggen onder de specificaties "naam van de gebruiker", werkgroep = WORKGROUP en wachtwoord. Daaronder nog enige inlogopties met daarin: "wachtwoord vergeten, wachtwoord onthouden tot wanneer U zich afmeldt en wachtwoord voor altijd onthouden. En hier stond den ezel bij mij natuurlijk stil!!! Wat ik dus moest doen is bij "naam van de gebruiker" mijn inlogaccount bij Hotmail opgeven (bij mij was dat strandkruier@hotmail.com) en niet Norbert2 en dan het al toegekende wachtwoord voor mijn W10-pc (ik dacht dat dit net hetzelfde wachtwoord is als van je e-mailaccount bij Hotmail, maar het is lang geleden dat ik nog mails gelezen heb bij Hotmail). Jullie herinneren jullie wellicht wel dat jullie, voor het installeren van W10, een Hotmailaccount nodig hebben en het was dus déze die benodigd was! En bij de opties heb ik aangevinkt "wachtwoord voor altijd onthouden."
En daarna ging het perfect!! Ik kreeg op slag toegang tot àlle gedeelde mappen in mijn W10-pc, na (eenmaal) "anonymous" inloggen. Toen heb ik mijn Ubuntu-pc stilgelegd en opnieuw opgestart en toen kreeg ik nà de heropstart opnieuw te maken met het venstertje "Verbinden met de server" nà in Nautilus geklikt te hebben op "Met de server verbinden." Dan was het weer ingave van smb://norbert2/ en toen ik kreeg ik alle gedeelde mappen van mijn W10-pc ineens voorgeschoteld, met volledige toegang, zonder wachtwoord en ook niet meer met "anonymous inloggen. "
Ziezo, dat was het dus, lieve mensen!! Zucht, wat een omslag toch allemaal! Heb ik daar 3 dagen mee bezig geweest!

Norbert

Offline youpie123

  • Lid
  • Steunpunt: Ja
Re: Probleem met bestandsdelen nà upgrade naar Ub.16.04
« Reactie #7 Gepost op: 2017/02/27, 15:34:04 »
Dan had Jan toch gelijk, wat een raar systeem dat Windows  ^-^
Groeten, Joep
Ubuntu Mate 16.04.2 op een Intel XEON 3460 Server

Offline Strandkruier

  • Lid
    • Mijn (eenvoudige) website
  • Steunpunt: Nee
Re: Probleem met bestandsdelen nà upgrade naar Ub.16.04
« Reactie #8 Gepost op: 2017/02/27, 16:27:13 »
Ik moet toegeven, Youpie123, dat ik dit probleem misschien sneller had kunnen oplossen. Ik had deze gang van zaken al voordien tegengekomen, op de Ubuntu-pc die, zoals door mij vermeld, voortreffelijk inlogde op mijn W10-pc. Die pc heeft de laatste 2 jaar op U14.04 gewerkt. Toen moet ik ook eens ingelogd hebben met mijn Hotmailaccount + wachtwoord want in de omgeving van /etc/samba/ was toen een bestandje te vinden waarin ook mijn hotmailaccount vermeld stond (na de upgrade naar 16.04 niet meer). Dat moet toen blijkbaar goed afgelopen zijn want ineens werkte het, ook nà de upgrade naar 16.04. Maar door de chaos van handelingen, die ik toen uitvoerde om de boel te laten werken, wist ik niet goed meer wat me eigenlijk geholpen had!! Sla me dood maar ik weet echt niet meer hoe en wat ik toen allemaal uitgeprobeerd heb en bovendien was het al een hele tijd geleden.
Maar, inderdaad, ik ben helemaal niet zo happig meer op Windows. Ik houd het nog aan op 1 pc (voor mezelf) omdat er nog altijd programma's zijn die in Linux niet goed werken. En, ja, ik merk het ook op bij andere mensen: als zij met Ubuntu leren werken hebben gaat hun voorkeur uit naar dit systeem en laten ze Windows vallen.

Norbert