Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: [Ubuntu Server 16.04.2 LTS] OpenVPN wel verbinden maar geen internet doorvoer  (gelezen 980 keer)

Offline Noxious Inc.

  • Lid
    • AMRis-ICT
  • Steunpunt: Nee
Beste forumleden,

Ik zit met het volgende probleem dat ik via OpenVPN een VPN verbinding naar huis heb gerealiseerd en deze redelijkerwijs werkend heb draaien.

Nu ben ik een x aantal weken bezig geweest om dit volledig te optimaliseren en dat is in principe ook gelukt, ware het niet dat ik vandaag wederom tegen het probleem aanloop dat, zodra ik de verbinding heb opgezet overal bij kan intern op mijn thuisnetwerk echter ik niet verder het internet op kom.

Ik heb de volledig 'how-to' van DigitalOcean doorlopen en een additionele 'root' crontab aangemaakt:

0 * * * * iptables -t nat -A POSTROUTING -s 10.8.0.0/24 -j SNAT --to MY_IP && iptables -L -n -v
*/5 * * * * ping -c10 8.8.8.8
*/15 * * * * ping -c10 8.8.4.4

Dit heeft meerdere dagen goed gewerkt maar nu loopt er weer geen 'extern' internet verkeer over...

Iemand een suggestie?
Laptop: Fedora 25 Workstation | 4.9.13-200 | HP ENVY Sleekbook 4 | Intel i5-3337U (2.7GHz) | Intel HD4000
1st Server: Ubuntu 16.04.2 LTS | 4.4.0-64 | ProLiant ML115 G1 | AMD Opteron 1216 (2.4GHz)
2th Server: Ubuntu 16.04.2 LTS | 4.4.0-64 | Compaq CQ2200NL | Intel Atom 230 (1.6GHz)

Offline testcees

  • Documentatieteam
    • testcees
    • www.testcees.nl
  • Steunpunt: Nee
De eerste regel in de crontab begrijp ik niet, deze voegt ieder heel uur een nat regel toe met iptabes -A? Zoals ik het begrijp krijg je er dus dagelijks 24 nat regels bij.
Zie eventueel sudo iptables -t nat -L

Weet je zeker dat je deze regel in crontab wil, normaal gesproken geef ik zo’n iptables opdracht éénmalig

https://help.ubuntu.com/community/IptablesHowTo
« Laatst bewerkt op: 2017/02/22, 07:29:23 door testcees »
Ik heb zojuit de Sleepnet-kieswijzer ingevuld op www.waartrekjijdegrens.nl/

Offline Noxious Inc.

  • Lid
    • AMRis-ICT
  • Steunpunt: Nee
Hi testcees,

Klopt, persoonlijk was het voor mij ook vreemd om deze toe te voegen daar de 'ufw' sowieso 'disabled' is. Alleen was het wel zo dat na dit toe te voegen, de internet doorvoer wel plaats vond. Alleen voor een bepaalde periode, daarom heb ik een cronjob gemaakt om deze elk uur te 'heractiveren' en dat ging vooralsnog goed. Naar gebleken is dit dus niet de oplossing want gisteren en vandaag is er wederom geen doorvoer, en de drie dagen daarvoor wel.

Ik heb de cronjobs tijdelijk even 'uncommented' om te zien wat er nu gebeurd.

Wel kan ik van buitenaf via ssh bij de server komen, ook dit werd soms gehinderd om welke rare reden ook.
Laptop: Fedora 25 Workstation | 4.9.13-200 | HP ENVY Sleekbook 4 | Intel i5-3337U (2.7GHz) | Intel HD4000
1st Server: Ubuntu 16.04.2 LTS | 4.4.0-64 | ProLiant ML115 G1 | AMD Opteron 1216 (2.4GHz)
2th Server: Ubuntu 16.04.2 LTS | 4.4.0-64 | Compaq CQ2200NL | Intel Atom 230 (1.6GHz)

Offline Noxious Inc.

  • Lid
    • AMRis-ICT
  • Steunpunt: Nee
Ben nu de server opnieuw aan het installeren, en begin even 'from scratch'...

Resultaat zal ik hier plaatsen... :)
Laptop: Fedora 25 Workstation | 4.9.13-200 | HP ENVY Sleekbook 4 | Intel i5-3337U (2.7GHz) | Intel HD4000
1st Server: Ubuntu 16.04.2 LTS | 4.4.0-64 | ProLiant ML115 G1 | AMD Opteron 1216 (2.4GHz)
2th Server: Ubuntu 16.04.2 LTS | 4.4.0-64 | Compaq CQ2200NL | Intel Atom 230 (1.6GHz)

Offline Noxious Inc.

  • Lid
    • AMRis-ICT
  • Steunpunt: Nee
Zo, de server weer opnieuw ingericht en de gehele OpenVPN ingesteld op basis van deze how-to en naar het schijnt werkt deze nu optimaal. Heb een aantal tweaks gedaan die ik nog zal documenteren zodra ik de 'how-to' heb vertaald (daar was ik al mee bezig maar liep nog tegen problemen aan dus)
Laptop: Fedora 25 Workstation | 4.9.13-200 | HP ENVY Sleekbook 4 | Intel i5-3337U (2.7GHz) | Intel HD4000
1st Server: Ubuntu 16.04.2 LTS | 4.4.0-64 | ProLiant ML115 G1 | AMD Opteron 1216 (2.4GHz)
2th Server: Ubuntu 16.04.2 LTS | 4.4.0-64 | Compaq CQ2200NL | Intel Atom 230 (1.6GHz)