Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Beryl wit scherm  (gelezen 600 keer)

Guus

  • Gast
Beryl wit scherm
« Gepost op: 2007/05/06, 17:29:20 »
Ik draai al een tijde Beryl op mijn laptop maar nu krijg ik opeens een wit scherm als ik beryl-manager opstart

Eerst bleek emerald corrupt te zijn. Toen heb ik alles van beryl verwijderd (beryl,manager,emerald,emerald-themes)

Dit loste het probleem niet op.

Toen nog maar eens beryl opnieuw verwijderd en erop gezet. Deze keer geb ik ook de verborgen mappen verwijderd. Dit hielp ook niks

Specs:

Intel P4 2 Ghz
Ati Radeon 7500
256 MB RAM
Ubuntu 7.04

Wie heeft nog andere suggesties over hoe ik dat kan oplossen ?

Alvast bedankt,

~Guus

Guus

  • Gast
Beryl wit scherm
« Reactie #1 Gepost op: 2007/05/07, 08:51:55 »
niemand? :(

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Beryl wit scherm
« Reactie #2 Gepost op: 2007/05/07, 12:11:02 »
Gebruik je de open source drivers, of de closed source icm xgl?
Wat staat er in je xorg.conf?
Wat is de uitkomst van glxinfo |grep direct
Gebruik je de standaard beryl of heb je een andere repository toegevoegd?
Zie je foutmeldingen als je beryl-manager opstart via de terminal?

Guus

  • Gast
Beryl wit scherm
« Reactie #3 Gepost op: 2007/05/07, 16:19:08 »
Ik heb een ATI Radeon 7500 en gebruik de opensource drivers (ik heb ook geen extra drivers nodig volgens de Restricted Drivers Manager)

xorg.conf:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
Load    "dbe"
Load "glx"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
Driver "ati"
BusID "PCI:1:0:0"
Option  "XAANoOffscreenPixmaps"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-51
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "ATI Technologies Inc Radeon Mobility M7 LW [Radeon Mobility 7500]"
Monitor "Generic Monitor"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice     "stylus" "SendCoreEvents"
InputDevice     "cursor" "SendCoreEvents"
InputDevice     "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection
Section "Extensions"
        Option "Composite" "Enable"
EndSection
glxinfo:

guus@guus-laptop:~$ glxinfo |grep direct
direct rendering: Yes
Ik gebruik de officiele repository

Alle tests zijn geslaagd en rendering is AIGLX

Kan het misschien iets te maken hebben met het muisthema dat ik recentelijk gedownload heb?

het staat namelijk bij gnome-look onder X11 Mouse Theme's
Ik zal eens terugschakelen naar het normale muisthema en de uitkomst posten

Guus

  • Gast
Beryl wit scherm
« Reactie #4 Gepost op: 2007/05/07, 16:29:36 »
het muisthema bleek de fout te zijn