Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: TV Out op nVidia gForce FX 5200  (gelezen 1244 keer)

dJnEvS

  • Gast
TV Out op nVidia gForce FX 5200
« Gepost op: 2007/05/05, 15:22:03 »
Ik heb een nVidia gForce FX 5200 gekocht (PCI)
en daar zit ook TV Out op.. nu wil ik graag mijn bureaublad uitbreiden met mijn tv.
Ik heb em aangesloten met scart.
Opstarten ed werkt wel op de tv (laatie zien iig) maar zodra ik in gnome kom, is het beeld zwart
Hoe kan ik dit instellen dat ik beeld op mijn tv heb. (bureaublad uitbreiden)


Groet,
Sven

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
TV Out op nVidia gForce FX 5200
« Reactie #1 Gepost op: 2007/05/05, 15:57:39 »
Welke drivers heb je geïnstalleerd?
Voor jouw kaart heb je als het goed is "nvidia-glx-new" nodig.
Kijk even in Synaptic of dat pakket geïnstalleerd is.
Heb je in /etc/X11/xorg.conf de "nvidia" driver ingesteld?

Zo ja:
Dan kan je via het commando nvidia-settings de tv-out instellen.

dJnEvS

  • Gast
TV Out op nVidia gForce FX 5200
« Reactie #2 Gepost op: 2007/05/05, 16:10:08 »
hmmz
in synaptic heb ik nvidia-glx, geinstalleerd..
nvidia-glx-new staat er niet tussen..

en in nvidia-settings kan ik niks vinden van Tv Out.

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
TV Out op nVidia gForce FX 5200
« Reactie #3 Gepost op: 2007/05/05, 16:33:16 »
Gebruik je Feisty of Edgy?
In Edgy is nvidia-glx prima.
Voor de tv-out instellingen zie de volgende screenshot:

Druk op "detect displays" als je de tv aangesloten hebt.
Nu moet hij je tv zien, en kan je instellen hoe je het beeld op je tv wil hebben.

schoappied

  • Gast
TV Out op nVidia gForce FX 5200
« Reactie #4 Gepost op: 2007/05/05, 17:30:55 »
Ik zal me met mijn vraag even aansluiten in dit topic...

Ik heb een Geforce 4 Ti4200,  en krijg deze melding in mijn terminal als ik nvidia-settings run....

dirk@dirk-desktop:~$ nvidia-settings

ERROR: Error parsing configuration file '/home/dirk/.nvidia-settings-rc' on
       line 35: '0/RedBrightness=0,000000' (Trailing garbage).

als ik detect displays doe, moet ie mijn tv zien, maar dat doet ie niet... :(

What to do?

Edit: mwah de error is weg... maar snap nog weinig van hoe ik die tvout voor elkaar krijg...

dJnEvS

  • Gast
TV Out op nVidia gForce FX 5200
« Reactie #5 Gepost op: 2007/05/05, 18:00:07 »


staat niks bij... iig, niet wa ik nodig heb?


edit: ff linkje van afbeelding gemaakt

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
TV Out op nVidia gForce FX 5200
« Reactie #6 Gepost op: 2007/05/06, 03:53:27 »
Welke versie van ubuntu gebruik je precies?
Als het niet lukt via nvidia-settings, dan werkt misschien nvtv wel.
Ik weet alleen niet of die compatible is met alle drivers.

Heb je trouwens al een keer opnieuw opgestart terwijl je tv aan je computer hing?
Wat voor TV is het?
Op welke manier heb je hem aangesloten? Tulp, scart, svideo, component, etc?

@schoappied, verwijder dat bestand eens, en probeer het nog een keer.
Je tv is aangesloten en staat ook aan?
Hoe is die aangesloten?

dJnEvS

  • Gast
TV Out op nVidia gForce FX 5200
« Reactie #7 Gepost op: 2007/05/06, 12:43:54 »
ik gebruik ubuntu Edgy (6.10)
een antieke tv, erres (tjah)
scart aansluiting..

als ik em opnieuw opstart krijg ik wel beeld. met ubuntu logo etc..
maar zodra ik in x kom, is het beeld zwart....


zal nvtv zo ff probeeren
wel bedankt

dJnEvS

  • Gast
TV Out op nVidia gForce FX 5200
« Reactie #8 Gepost op: 2007/05/06, 13:00:51 »
# nvtv
Segmentation fault (core dumped)
edit:

# nvtv -d shows
init root
gui_main
settings_cb 0
settings_cb done 0
bnv open
bnv update crt 1
nv get devflags 0 [] = 01
nv get clock pll=00021401, m=1 n=20 p=2, Fref=13500 Fclk=67500 kHz
NVIsTimerActive: TRUE
NVIsTimerActive: TRUE
NVIsTimerActive: TRUE
bnv init heads 2
nv get devflags 0 [] = 01
nv get devflags 1 [] = 02
NVSetTvHead 1
NVAssoc 1 00001000
bnv update crt 2
nv get devflags 1 [] = 02
nv get clock pll=00021001, m=1 n=16 p=2, Fref=13500 Fclk=54000 kHz
bnv_probeChips
TVCreateChain 3 0
TVCreateChain 3 1
bnv_setChip NULL 0
gui_card_changed
bnv_getHeads
bnv_getHeadDev
nv get devflags 0 [] = 01
bnv_getHeadDev
nv get devflags 1 [] = 02
gui_device_init
gui_device_init end
get mode nv 2
bnv update crt 2
nv get devflags 1 [] = 02
nv get clock pll=00021001, m=1 n=16 p=2, Fref=13500 Fclk=54000 kHz
Segmentation fault (core dumped)

dJnEvS

  • Gast
TV Out op nVidia gForce FX 5200
« Reactie #9 Gepost op: 2007/05/06, 23:03:45 »
Ok, ik heb het voor elkaar gekregen om beeld te hebben op mijn tv..

echter nog geen dual screen..

xorg aangepast:
Section "Device"
Identifier "NVIDIA Corporation NV34 [GeForce FX 5200]"
Driver "nvidia"
BusID "PCI:0:11:0"
Option "UseFBDev" "true"
Screen 0
EndSection

# TV --- TV
Section "Device"
        Identifier      "Device1"
        Driver "nvidia"
        Option  "TVOutFormat" "SVIDEO"
        Option  "TVStandard" "PAL-B"
        Option  "ConnectedMonitor" "TV"
Screen 1
EndSection

Section "Monitor"
Identifier "Belinea10170"
Option "DPMS"
HorizSync 30-70
VertRefresh 50-160
EndSection

# TV --- TV
Section "Monitor"
        Identifier "Television" #TV
        HorizSync 30-50
        VertRefresh 60
EndSection

Section "Screen"
        Identifier      "Screen1"
        Device          "Device1"
        Monitor         "Television"
        DefaultDepth    24
        SubSection "Display"
            Depth 24
        Modes "1024x768" "800x600" "640x480"
        EndSubSection
EndSection

Section "Screen"
Identifier "Default Screen"
Device "NVIDIA Corporation NV34 [GeForce FX 5200]"
Monitor "Belinea10170"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

#Section "ServerLayout"
#        Identifier      "Basic Layout"
#        Screen          "Screen1"
#        InputDevice     "Generic Keyboard"
#        InputDevice     "Configured Mouse"
#EndSection

Section "ServerLayout"
Identifier "Default Layout"
#Screen "Screen1" RightOf "Default Screen"
    Screen 0 "Default Screen"
    Screen 1 "Screen1" RightOf "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice     "stylus" "SendCoreEvents"
InputDevice     "cursor" "SendCoreEvents"
InputDevice     "eraser" "SendCoreEvents"
EndSection
als ik de gecommente serverlayout uncomment, en de... je snapt me wel.
dan heb ik beeld op me tv
en andersom.