Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Uitvoeren van bestand toestaan  (gelezen 2142 keer)

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Gepost op: 2007/05/03, 23:28:10 »
Ik had gelezen dat je bijvoorbeeld een commando in een tekstbestandje (bv via gedit) kan plaatsen en dat je ervoor zorgt dat zodra je het bestand aanroept dit commando direct uitgevoerd wordt. Dit was dan in te stellen door rechtermuis op bestand -> rechten -> uitvoeren van bestand toestaan aanvinken.

Echter sinds kort werkt dit niet meer, en wordt gedit geopend waarin ik dan die command zie staan. Het heeft dus wel gewerkt, en ik zal waarschijnlijk iets veranderd hebben, echter weet ik niet wat. Als jullie het weten hoor ik dat graag :D

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #1 Gepost op: 2007/05/04, 17:22:13 »
Ik ben niet zo'n grafische interface liefhebber, maar als je die uitvoerrechten hebt aangepast en gedit opent i.p.v. dat het programma wordt uitgevoerd, dan zou je eens moeten kijken naar de bestands-associaties.  Daar heb ik in dit forum al eens meer over gelezen dus dat moet terug te vinden zijn.

Goed idee is ook om het programmaatje eerst eens te testen in de command-line omgeving. Open een terminal, ga naar de directory waar het staat en type: ./ waarbij je uiteraard vervangt door de naam van het ding. Zo weet je of het script/programma goed werkt en dan kun je de grafische handel erop aanpassen.
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #2 Gepost op: 2007/05/04, 17:39:31 »
met ./ wordt het uitgevoerd.. ik zal dus is zoeken naar bestands-associaties.


Edit: ik heb gekeken, en ja ik kan bijvoorbeeld instellen om het met xterm te openen, maar dat is niet echt de bedoeling, dan gaat die dat doen met alle tekstbestanden...

Vind het vreemd, maar het is niet het einde van de wereld..

Offline Tukcedo

  • Lid
    • http://www.tukcedo.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #3 Gepost op: 2007/05/05, 09:51:27 »
Het probleem is dat het nogal een simplistische benadering is waarschijnlijk die uitgaat van de file extensies (gok ik hoor). Dus scipts die eindigen op ".sh" zouden in een terminal worden uitgevoerd, en bestandjes die eindigen op ".txt" geopend in gedit bijv. Maar wat als je nu helemaal geen extensie gebruikt? Misschien moet je de naam van dat progje wel gewoon wat aanpassen ...
Tukcedo Services - Unix en Linux Consultants
http://www.tukcedo.nl

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #4 Gepost op: 2007/05/05, 17:15:32 »
Tja, het heeft nu helemaal geen extensie.. ik zal straks met .sh proberen.

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #5 Gepost op: 2007/05/05, 17:18:57 »
Gebruik het commando file en de magic numbers zullen je vertellen wat het is ;)

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #6 Gepost op: 2007/05/05, 18:16:27 »
Met .sh nog steeds wordt gedit geopend..

file test.sh  --> geeft test.sh: ASCII text...

Vind alleen het vreemde dat hij het wel heeft gedaan en nu niet meer.

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #7 Gepost op: 2007/05/05, 22:22:02 »
Het gaat toch vervelend worden.. blueJ maakt namelijk gebruik van een textbestand met zijn commando's om het te starten.. nu moet ik via een omweg blueJ starten. Weet niemand of dit ergens in 1 of ander bestand is in te stellen.. ?


Edit: dat bluej bestandje heeft als mime wel application/x-shellscript...

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #8 Gepost op: 2007/05/08, 20:34:31 »
Niemand blijkbaar een idee? Naja, dan is het zo, dan maar een omweg via een opdrachtstarter.

Offline Dominique Ramaekers

  • Lid
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #9 Gepost op: 2007/05/08, 20:53:28 »
Linux werkt niet met extenties om te kijken met welk programma het bestand geopend moet worden. Om te weten wat voor een soort bestand je wilt openen kan je het commando file gebruiken zoals hierboven werd vermeld.

Je moet linux dus vertellen dat je bestand een scrip is. Dit doe je door op de eerste regel #!/bin/sh te typen.

Ik veronderstel dat je Gnome gebruikt:
druk met de rechter muisknop op het bestand
druk op "eigenschappen"
druk op "rechten"
vink aan "uitvoeren van bestand toestaan".

Dit laatste kan je ook doen door het comando in het terminalvenster "chmod +x [bestand]"

Help dit ;)

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #10 Gepost op: 2007/05/08, 21:08:49 »
Dankje voor poging, alles gedaan wat je zei. Maar zodra ik op het aangemaakte bestandje druk, hop, gedit wordt geopend en daar zie ik de letterlijke tekst in inclusief #!/bin/sh.

Offline zappa

  • Lid
    • http://www.c3c.be
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #11 Gepost op: 2007/05/08, 22:17:34 »
Citaat van: dvdmeer
I...wordt gedit geopend waarin ik dan die command zie staan. Het heeft dus wel gewerkt, en ik zal waarschijnlijk iets veranderd hebben, echter weet ik niet wat. Als jullie het weten hoor ik dat graag :D
Dan is het niet meer uitvoerbaar of heb je 'openen met' zitten veranderen.

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #12 Gepost op: 2007/05/08, 22:22:36 »
Dat er iets is veranderd, daar ben ik ook achter. Ik vraag me alleen af hoe dat terug is te draaien, en waar.

Offline Dominique Ramaekers

  • Lid
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #13 Gepost op: 2007/05/09, 07:52:10 »
't Is misschien een verre gok maar:
rechter muisknop op het bestand.
druk "Met andere toepassing openen"
druk "Gebruik een aangepaste opdracht"
Type daar in "nautilus" en "bash" kan je ook eens proberen

Werkt één van deze?

ps: wat krijg je als je
    ls -l |grep [bestand]        type in het terminal venster?

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #14 Gepost op: 2007/05/09, 13:51:34 »
Allereerst plaats ik hier mijn xorg. conf
dat is het enige bestand waar ik ooit wat in heb gewijzigd(en teruggedraaid) maar misschien toch nog iets fout...

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller"
Driver "i810"
BusID "PCI:0:2:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 28-64
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Mobile 945GM/GMS/940GML Express Integrated Graphics Controller"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x800"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x800"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice     "stylus" "SendCoreEvents"
InputDevice     "cursor" "SendCoreEvents"
InputDevice     "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
Mode 0666
EndSection
Als ik bash als opdracht geef, inderdaad dan doet hij het.

Met je commando krijg ik:

"-rwxr-xr-x 1 dennis dennis     16 2007-05-09 13:52 test"


Mocht het niet gaan lukken, dan zal ik linux opnieuw installen.. schone installatie. En dan maak ik ook gelijk een home partitie aan. (heb ruimte vrijgemaakt door wat windows programma's eraf te keilen.

Maar goed, ik hoop natuurlijk dat je of iemand anders een oplossing weet.

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #15 Gepost op: 2007/05/10, 19:24:05 »
Zit er nog wat vreemds in dat bestandje?

Offline Dominique Ramaekers

  • Lid
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #16 Gepost op: 2007/05/12, 09:43:54 »
Gek, niets vreemds te zien.

Ik ben nog wat aan het uitzoeken. Maar kan zo direct niets vinden...

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #17 Gepost op: 2007/05/12, 14:19:39 »
Oke, ik wacht nog af of je nog iets kan bedenken, anders een schone installatie.

Offline markba

  • Lid
    • http://markbaaijens.nl/
  • Steunpunt: Ja
Uitvoeren van bestand toestaan
« Reactie #18 Gepost op: 2007/05/12, 15:31:04 »
Waarom hecht je zo aan het uitvoeren van een script via een dubbelklik binnen Nautilus? Persoonlijk (maar wie ben ik) start ik nooit een bash-script op maar verbindt deze aan een starter. Die starter kan ik vervolgens op het bureaublad plaatsen of ergens anders.

Blijkbaar vindt jij dit zo belangrijk dat je overweegt om opnieuw Linux te installeren. Let op: blijkbaar heb jij (en velen die deze draad gelezen hebben) de oorzaak van het probleem niet opgespoord. Het zou zo maar kunnen dat je dan binnen korte tijd weer hetzelfde probleem krijgt.

Offline dvdmeer

  • Lid
    • Python-RandR :: dvdmeer.nl
  • Steunpunt: Nee
Uitvoeren van bestand toestaan
« Reactie #19 Gepost op: 2007/05/12, 15:52:13 »
Nee dit niet de rede voor nieuwe installatie, ik wil ook windows kleiner maken, en linux meer ruimte geven.
Dat ik er zoveel waarde aan hecht? "Zoveel" is een groot woord, maar omdat het gewoon eenmaal hoort te kunnen, hoort het te kunnen :P

Met zo'n starter, ja dat doe ik nu ook, maar dat is wel 1 bestandje extra :P
Maar opnieuw installeren doe ik nu nog niet, ik ga eerst nog een beetje knutselen met ubuntu en dingen uitvinden/uitvogelen.