Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Ubuntu en veiligheidsupdates  (gelezen 3957 keer)

Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Re: Ubuntu en veiligheidsupdates
« Reactie #50 Gepost op: 2013/04/14, 11:13:15 »
@Dave: Dan nog is het naar mijn mening voor die stagiaries beter als je er even snel een lichte distro oppleurt, is zo gepiept en heb je een mooie up-to-date distro die prima werkt op een oud bakje. Maar goed, laten we er maar over ophouden, de TS is volgens mij wel geholpen zo...

Offline Dave

  • Lid
  • Steunpunt: Nee
Re: Ubuntu en veiligheidsupdates
« Reactie #51 Gepost op: 2013/04/15, 10:52:58 »
@Dave: Dan nog is het naar mijn mening voor die stagiaries beter als je er even snel een lichte distro oppleurt, is zo gepiept en heb je een mooie up-to-date distro die prima werkt op een oud bakje. Maar goed, laten we er maar over ophouden, de TS is volgens mij wel geholpen zo...

Voor de langere termijn is dat zeker de beste optie.
Normaal zijn er ook maar 1 of 2 stagiaires en nu ineens 4 dus.
Die andere oude bak waar ik het eerder over had en 8.04 nog op stond had ik vorige week wel een nieuwere versie (Xubuntu)opgezet maar was niet meer vooruit te branden.
Had er gelijk spijt van en toen XP er maar opgezet.(was een kwestie van een andere schijf want had voorheen legio van die machines) en updates opgehaald.
Want die 8.04 die er op stond had natuurlijk al z'n updates die nu niet meer beschikbaar zijn.
Ik had er beter af kunnen blijven en bij die andere 2 machines dus ook maar gedaan.

Overigens, forumsoftware behoeft ook veiligheidsupdates en daar werd jarenlang nauwelijks naar omgekeken hier.
Een gehackt linux forum, nou daar smullen velen van hoor en was de schade vele malen groter geweest dan met zo'n oud IBM gebakje wat dan hooguit even een ongemakje is.





Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Re: Ubuntu en veiligheidsupdates
« Reactie #52 Gepost op: 2013/04/15, 11:48:24 »
Hier? Je bedoelt als in Ubuntu-NL? Dat is fout. We hebben alle security-updates doorgevoerd. SMF bleef updates geven voor 1.1.x toen 2.0 al bijna af was en op eentje na hebben we die doorgevoerd (alleen die laatste niet omdat er toen gewerkt werd aan overschakelen naar 2.0).

En als je bedoelt in het algemeen: ik ken inderdaad een paar fora waar men daar niet naar omkeek maar de meesten toch echt wel hoor.

Offline Lowlands

  • Lid
  • Steunpunt: Nee
Re: Ubuntu en veiligheidsupdates
« Reactie #53 Gepost op: 2013/04/15, 13:20:33 »
Soms kan het toch makkelijker zijn om gewoon een oude, niet meer ondersteunde versie te gebruiken. Natuurlijk moeten je het niet als voorkeursmethode gaan aanraden maar je kunt per geval bekijken wat het makkelijkst is. Wat is er mis mee als iemand er bewust zelf voor kiest (met kennisneming van de risoco's)?

Feit is dat het nogal eens voorkomt dat oudere hardware in een nieuwe versie van Ubuntu niet meer zo goed wordt ondersteund. Neem bijvoorbeeld Nvidia-kaartjes. Voor hele oude modellen (denk aan een Riva TNT2) worden sinds een paar jaar geen drivers meer aangeboden via Jockey. Toch verreweg de makkelijkste installatiemethode in Ubuntu. Versie 7.10 (even puur als voorbeeld uit mijn eigen ervaring) biedt nog wel drivers voor deze kaart aan op de makkelijke manier. Versie 7.10 is nog prima bruikbaar in combinatie met de old-releases repository. Natuurlijk onveilig maar wat is de kans op aanvallen als je er verder geen gekke dingen mee doet? Ik denk in de praktijk verwaarloosbaar. Denk dat er maar weinig malwarebakkers geïnteresseerd zijn in die paar computertjes waar een verlaten versie van Gnome op staat, om maar iets te noemen. Veel van de software die nu actief wordt uitgebuit draait niet eens op die oude bakjes en is er ook niet standaard op geïnstalleerd.

De risico's die je neemt zijn dan vrij groot. Je kan geen spelletjes of 3d toepassingen meer gebruiken, vanwege bugs zoals deze.
Browsen en je mail lezen is ook levensgevaarlijk, zoek zelf maar eens op veiligheidsgaten die bekend zijn in oude versies van Firefox of Thunderbird.

En dan zijn er ook nog fundamentelere problemen: lekken in de kernel, maar ook lekken in de library's die alle programma's gebruiken. Denk dan aan functies om plaatjes weer te geven, het netwerk te gebruiken of om met XML-bestanden te werken.

Wil je zo'n antieke versie van Ubuntu veilig gebruiken, dan kan je die dus niet aansluiten op het internet en kan je ook geen bestanden vanaf andere computers via een USB stick overzetten.
Ik weet niet hoe jij je computer gebruikt, maar voor mij zou hij dan redelijk nutteloos worden.

Een Linuxversie gebruiken die wel bij de tijd is hoeft ook niet te betekenen dat je computer veel trager wordt. Je hoeft niet per se Ubuntu te gebruiken, je kan ook kiezen voor Lubuntu, Bodhi, Puppy of gewoon kaal Debian.
Verder moet je er ook rekening mee houden dat een computer op een gegeven moment gewoon op is. Je kan niet van een computer uit het jaar 2000 verwachten dat hij alle functies kan vervullen die een computer uit 2013 kan. Wil je per se die oude bak nog gebruiken, zet hem dan alleen in voor dingen die nog wel mogelijk zijn. Bijvoorbeeld als simpele file server of zo. Maar in zo'n geval kan je beter overstappen op een recent systeem omdat die veel minder stroom gebruiken. Alleen al van de kosten die je daarop bespaart kan je de aanschaf van een Raspberry of simpel Atom systeem bekostigen.
Ik ben met 8.04 begonnen,kan me niet herinneren dat ik daar uberhaupt problemen had met lekken of andere dingen.Ok,we leven nu een tijd later,maar de browser is nieuw en de emailclient ook!En via deze proggies moet men dan toch binnen zien te komen om problemen te veroorzaken...En die zijn dan toch door hun updates dicht getimmerd.

Tuurlijk in WINDOWS is dat niet genoeg,daar heb je dan even goed een virusscanner en firewall nodig.Maar ik heb daar nooit de behoefte voor gezien in Ubuntu!En je KAN een virus door geven ook al werkt die niet in Ubuntu,nou gewoon niks door geven!Waarom zou je ook?
Doe rustig aan,ben ik ook de hele dag druk mee.

Offline Dave

  • Lid
  • Steunpunt: Nee
Re: Ubuntu en veiligheidsupdates
« Reactie #54 Gepost op: 2013/04/15, 21:00:04 »
De standaard browser in windows is nogal verweven in het systeem.
Zelfs als je die verwijderd kun je in de verkenner nog online  :police:
1 van de redenen van de vele lekken, dat integreren om de concurentie te slim af te zijn.
Maar voor die internet zaken heb je legio alternatieven, nét als bij een oudere Linux versie.
Is allemaal apart te updaten.

updates voor de firewall nog wel eens langs zien komen?






Offline Vistaus

  • Lid
    • vistaus
  • Steunpunt: Nee
Re: Ubuntu en veiligheidsupdates
« Reactie #55 Gepost op: 2013/04/15, 21:43:39 »
De standaard browser in windows is nogal verweven in het systeem.

Ja want op Ubuntu is dat wel beter wil je zeggen. Sorry hoor, maar als ik bijv. Opera of Qupzilla erop zet dan openen links niet standaard in iets anders dan Firefox, zelfs niet na instellingen in de systeeminstellingen. Ik moet eerst sudo apt-get install galternatives doen en dan X-www-browser en gnome-www-browser instellen voordat het wel werkt.
Ik heb dit al een paar versies lang, zelfs na een schone installatie dus aan mijn installatie ligt het niet.

Ik vind het geen probleem hoor, ik vind het wel leuk om dat steeds weer in te stellen maar om nu te zeggen dat het eenvoudig is? Nou, nee. Firefox zit dus toch aardig verweven...