Nieuws:

We zijn er weer.

Na lange tijd van afwezigheid zijn we er weer  :laugh:
We hebben alle wachtwoorden gereset, je oude wachtwoord werkt niet meer.Je moet via het "wachtwoord vergeten"-linkje je wachtwoord resetten. Je krijgt hiervoor een mailtje op het adres dat je bij ons geregistreerd hebt.

De komende tijd zijn we nog druk bezig om de rest van de site op te bouwen, dus het kan zijn dat sommige onderdelen (tijdelijk) niet werken.

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: K3B voor KDE 4  (gelezen 7970 keer)

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
K3B voor KDE 4
« Gepost op: 2009/01/16, 20:09:30 »
Ik erger me geruime tijd aan K3B's interface. Die stamt nog uit KDE 3, en ziet er niet mooi uit op mijn KDE 4 desktop. Ik dacht: laat ik eens gaan kijken in de SVN. Ik heb K3B uit de SVN gecompileerd, en zie hier:

http://imagebin.ca/view/WZ06u4.html

http://imagebin.ca/view/juHf2r.html

http://imagebin.ca/view/H0RrxUo.html


Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #1 Gepost op: 2009/01/16, 20:15:08 »
Ik wilde kort geleden ook de KDE 4 versie installeren vanuit een of andere repo, maar toen zei ie dat er pakketten gebroken gingen worden. Dankjewel dat je me even op het idee van de svn-versie bracht, want daar heb ik dom genoeg niet aan gedacht ;)

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #2 Gepost op: 2009/01/16, 21:17:34 »
k3b svn versie is geïnstalleerd! Zo hee, wat ziet dat er schitterend uit zeg! Dat is stukken beter dan die lelijke KDE3-versie!

Alleen, hoe krijg ik hem zover dat ie de MP3 plugin vindt? Want ik krijg nu steeds bij het opstarten de melding dat ie de MP3 plugin niet kan vinden en dat ik libmad moet installeren.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #3 Gepost op: 2009/01/17, 16:38:42 »
bump

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #4 Gepost op: 2009/01/17, 17:17:41 »
Gokje: libmad0-dev installeren, of iets dergelijks.
En bij het compilen aangeven dat hij libmad moet gebruiken.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #5 Gepost op: 2009/01/17, 17:26:16 »
Adept zegt dat libmad0-dev al is geïnstalleerd.
En er werd niks aangegeven bij het compilen.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #6 Gepost op: 2009/01/17, 17:27:35 »
k3b svn versie is geïnstalleerd! Zo hee, wat ziet dat er schitterend uit zeg! Dat is stukken beter dan die lelijke KDE3-versie!

Alleen, hoe krijg ik hem zover dat ie de MP3 plugin vindt? Want ik krijg nu steeds bij het opstarten de melding dat ie de MP3 plugin niet kan vinden en dat ik libmad moet installeren.
Is de Xine MP3 plugin geïnstalleerd?

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #7 Gepost op: 2009/01/17, 20:15:29 »
Welk pakket is dat? (de xine mp3 plugin) Want ik kan hem zo snel niet vinden in Adept.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #8 Gepost op: 2009/01/17, 20:19:20 »
Welk pakket is dat? (de xine mp3 plugin) Want ik kan hem zo snel niet vinden in Adept.
xine-plugins ofzo.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #9 Gepost op: 2009/01/17, 20:22:05 »
Ik heb geen pakket dat "xine-plugins" heet. Wel een pakket "xine-plugin" maar dat is een plugin voor Mozilla-based browsers.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #10 Gepost op: 2009/01/17, 20:22:56 »
libxine1-all-plugins
libxine1-plugins 
libxine1-misc-plugins 

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #11 Gepost op: 2009/01/17, 20:25:49 »
Zijn allemaal geïnstalleerd.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #12 Gepost op: 2009/01/17, 20:43:59 »
Een linkje: http://linuxappfinder.com/blog/howto_enable_mp3_support_for_k3b
Is wel een bericht van 2007 dit pakket:  libk3b3-extracodecs   zit wel in Synaptic (Er staan er nog een paar)

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #13 Gepost op: 2009/01/17, 21:10:20 »
@heir4c: Bedankt, maar dat pakekt is ook al geïnstalleerd.

Offline heir4c

  • Lid
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #14 Gepost op: 2009/01/17, 21:21:56 »
hier nog iets, je kan nooit niet weten: http://blog.darrenvickers.co.uk/2008/03/28/burn-an-mp3-with-k3b
Gaat over Fedora maar staat iets in over ubuntu.

Heb gezocht via google met: MP3 plugin+k3b+SVN

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #15 Gepost op: 2009/01/17, 21:27:13 »
Dankjewel, maar nog steeds zeurt K3B. Ik heb zoals die turorial zei "madplay" nog geïntalleerd en zelfs de XMMS2-mp3 plugin. Maar het heeft niet geholpen.

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #16 Gepost op: 2009/01/20, 20:49:54 »
Dan staan de padenvariabelen niet goed, denk ik. Dat moet je aanpassen tijdens het compileren.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #17 Gepost op: 2009/01/21, 15:06:00 »
Dan staan de padenvariabelen niet goed, denk ik. Dat moet je aanpassen tijdens het compileren.

Die staan wel goed. En op die foutmelding na werkt ie harstikke goed.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #18 Gepost op: 2009/01/24, 17:32:49 »
Hoe compileer je K3B eigenlijk op Kubuntu 8.10? Want ik krijg steeds een foutmelding:

heimen-at-kubuntu@heimen-at-compaq:~/kdemultimedia-extragear/build$ cmake ..
-- Found Qt-Version 4.4.3 (using /usr/bin/qmake)                           
-- Found X11: /usr/lib/libX11.so                                           
CMake Error at /usr/share/kde4/apps/cmake/modules/FindPhonon.cmake:15 (file):
  file Internal CMake error when trying to open file:                       
  /usr/lib/kde4/include/phonon/phononnamespace.h for reading.               
Call Stack (most recent call first):                                         
  /usr/share/kde4/apps/cmake/modules/FindPhonon.cmake:41 (_phonon_find_version)
  /usr/share/kde4/apps/cmake/modules/FindKDE4Internal.cmake:1153 (find_package)
  /usr/share/cmake-2.6/Modules/FindKDE4.cmake:81 (FIND_PACKAGE)               
  CMakeLists.txt:6 (find_package)                                             


-- Found KDE 4.2 include dir: /usr/include
-- Found KDE 4.2 library dir: /usr/lib   
-- Found the KDE4 kconfig_compiler preprocessor: /usr/bin/kconfig_compiler
-- Found automoc4: /usr/bin/automoc4                                     
-- Found taglib: -L/usr/lib/kde4/lib -ltag                               
-- Taglib found: -L/usr/lib/kde4/lib -ltag                               
-- Found MySQL: /home/heimen-at-kubuntu/usr/include/mysql, /home/heimen-at-kubuntu/usr/lib/mysql/libmysqlclient.a
-- Found MySQL Embedded: /home/heimen-at-kubuntu/usr/include/mysql, /home/heimen-at-kubuntu/usr/lib/mysql/libmysqld.a
Qt QTNSPLUGIN library not found.                                                                                     
-- Found taglib: -L/usr/lib/kde4/lib -ltag                                                                           
-- Taglib found: -L/usr/lib/kde4/lib -ltag                                                                           
-- Strigi API needs 'signed char'                                                                                   
-- Found MySQL: /home/heimen-at-kubuntu/usr/include/mysql, /home/heimen-at-kubuntu/usr/lib/mysql/libmysqlclient.a   
-- Found MySQL Embedded: /home/heimen-at-kubuntu/usr/include/mysql, /home/heimen-at-kubuntu/usr/lib/mysql/libmysqld.a
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig                                           
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig                                           
-- PKGCONFIG() indicates that libgpod-1.0 is not installed (install the package which contains libgpod-1.0.pc if you want to support this feature)                                                                                                                                         
-- Could NOT find Ipod  (missing:  IPOD_INCLUDE_DIR IPOD_LIBRARIES)                                                                           
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig                                                                   
-- PKGCONFIG() indicates that libmtp is not installed (install the package which contains libmtp.pc if you want to support this feature)     
-- Found MTP but version requirements not met                                                                                                 
-- Libgcrypt found: /lib/libgcrypt.so                                                                                                         
-- Found GObject libraries: /usr/lib/libgobject-2.0.so;/usr/lib/libgmodule-2.0.so;/usr/lib/libgthread-2.0.so;/usr/lib/libglib-2.0.so         
-- Found GObject includes : /usr/include/glib-2.0/gobject                                                                                     
-- Found Soprano: /usr/lib/libsoprano.so                                                                                                     
-- Found Soprano includes: /usr/include                                                                                                       
-- Found Soprano Index: /usr/lib/libsopranoindex.so                                                                                           
-- Found Soprano Client: /usr/lib/libsopranoclient.so                                                                                         
-- Found Soprano Plugin Dir: /usr/share/soprano/plugins                                                                                       
-- Found Soprano Plugins: nquadparser nquadserializer raptorparser raptorserializer redlandbackend                                           
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig                                                                   
-- PKGCONFIG() indicates that libgpod-1.0 is not installed (install the package which contains libgpod-1.0.pc if you want to support this feature)                                                                                                                                         
-- Could NOT find Ipod  (missing:  IPOD_INCLUDE_DIR IPOD_LIBRARIES)                                                                           
--                                                                                                                                           
-----------------------------------------------------------------------------                                                                 
-- The following external packages were located on your system.                                                                               
-- This installation will have the extra features provided by these packages.                                                                 
+ kdelibs                                                                                                                                     
+ taglib                                                                                                                                     
+ strigi                                                                                                                                     
+ mysqld                                                                                                                                     
+ zlib                                                                                                                                       
+ glib2                                                                                                                                       
+ Gdk                                                                                                                                         
+ libmp4v2                                                                                                                                   
+ curl                                                                                                                                       
+ libxml2                                                                                                                                     
+ openssl or libgcrypt                                                                                                                       
+ gobject                                                                                                                                     
+ loudmouth                                                                                                                                   
+ soprano                                                                                                                                     
+ nepomuk                                                                                                                                     
+ Qt4 Glib support                                                                                                                           
-----------------------------------------------------------------------------                                                                 
-- The following OPTIONAL packages could NOT be located on your system.                                                                       
-- Consider installing them to enable more features from this software.                                                                       
+ libgpod, 0.6.0 or higher: Support Apple iPod audio devices <http://sourceforge.net/projects/gtkpod/>                                       
+ libmtp, 0.3.0 or higher: Enable Support for portable media devices that use the media transfer protocol <http://libmtp.sourceforge.net/>   
-----------------------------------------------------------------------------                                                                 

-- Found taglib: -L/usr/lib/kde4/lib -ltag
-- Taglib found: -L/usr/lib/kde4/lib -ltag
-- DCOP stuff was remove into kde4, convert it to dbus please.kde4_add_dcop_skels macro doesn't exist now. We keep it just to remember to port to dbus                                                                                                                                     
-- Found OggVorbis: /usr/lib/libogg.so;/usr/lib/libvorbis.so;/usr/lib/libvorbisfile.so;/usr/lib/libvorbisenc.so                               
-- checking for module 'libavcodec'                                                                                                           
--   package 'libavcodec' not found                                                                                                           
-- Could NOT find FFMPEG                                                                                                                     
-- Could not find Flac++                                                                                                                     
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig                                                                   
-- audioprojectcddb disable for the moment need to port it to                                                                                 
kccd                                                                                                                                         
-- audiometainforenamer disable for the moment need to port to                                                                               
strigi ?                                                                                                                                     
-- Looking for doxygen...                                                                                                                     
-- Looking for doxygen... - NOT found                                                                                                         
-- Looking for dot tool...                                                                                                                   
-- Looking for dot tool... - NOT found                                                                                                       
--                                                                                                                                           
-----------------------------------------------------------------------------                                                                 
-- The following external packages were located on your system.                                                                               
-- This installation will have the extra features provided by these packages.                                                                 
+ taglib                                                                                                                                     
+ musicbrainz                                                                                                                                 
+ dvdread                                                                                                                                     
Congratulations! All external packages have been found.
-----------------------------------------------------------------------------

-- Found ALSA: /usr/lib/libasound.so
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
-- WARNING: you are using the obsolete 'PKGCONFIG' macro use FindPkgConfig
have cairo cflags: ldflags:-lcairo;-lpangocairo-1.0 -lpango-1.0 -lcairo -lgobject-2.0 -lgmodule-2.0 -lglib-2.0
extra -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include  libs -lcairo -L//lib -ldbus-glib-1 -ldbus-1 -lgobject-2.0 -lglib-2.0
build npp
--

--

-- Configuring incomplete, errors occurred!

Op 8.04 ging het op dezelfde manier wél foutloos.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #19 Gepost op: 2009/01/25, 11:19:47 »
bump

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #20 Gepost op: 2009/01/25, 11:31:44 »
Omdat ik KDE zelf compileer, heb ik de volgende packages nodig:
http://techbase.kde.org/Getting_Started/Build/KDE4/Kubuntu_and_Debian
K3B compileert hiermee zonder moeite.

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #21 Gepost op: 2009/01/25, 13:15:18 »
Dankjewel, nu gaat het compileren wél goed :)

Offline Vistaus

  • Webteam
    • vistaus
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #22 Gepost op: 2009/01/25, 13:35:02 »
Ok hij is nu goed gecompileerd, alleen hij start alleen vanaf de Terminal. Op 8.04 ging het ook vanuit Kickoff ???

Edit: Probleem opgelost. Heb de KDE 3 versie verwijderd en nu start de KDE 4 versie gewoon vanuit Kickoff op. Alleen krijg ik nog steeds die melding van dat de MAD mp3 plugin niet geïnstalleerd is, zoals eerder in dit topic aangegeven ???
« Laatst bewerkt op: 2009/01/25, 13:39:46 door Vistaus »

Offline Typhoner

  • Lid
    • http://typhoner.blogspot.com/
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #23 Gepost op: 2009/02/19, 21:02:04 »
En drie dagen geleden zijn drie devs opeens als een gek beginnen te committen in de svn, na maanden inactiviteit. Het begint er terug een beetje rooskleurig uit te zien.  :)
« Laatst bewerkt op: 2009/02/19, 21:05:02 door Typhoner »

Offline Cumulus007

  • Lid
  • Steunpunt: Nee
Re: K3B voor KDE 4
« Reactie #24 Gepost op: 2009/02/20, 21:39:35 »
jeej :D