Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Kan Compiz niet updaten??  (gelezen 3845 keer)

Offline Joop2

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Gepost op: 2008/03/09, 19:28:21 »
Ik kreeg de melding dat er een aantal updates waren waaronder Compiz en Emerald.
Deze worden alleen om een of andere reden achter gehouden (ze staan wel in mn update lijst maar kan ze niet aanklikken)

Deze melding krijg ik via mn terminal venster

root@joop-ubuntu:/home/joop# sudo apt-get upgrade
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
De volgende pakketten zijn achtergehouden:
  emerald gnome-compiz-manager libemeraldengine0 libgnome-compiz-manager0
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 4 niet opgewaardeerd.
root@joop-ubuntu:/home/joop#

Nu is Compiz helaas ook niet meer actief.

Iemand hier mee bekend?
“Dream as if you'll live forever, Live as if you'll die tomorrow.”

Offline Mij

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #1 Gepost op: 2008/03/09, 19:38:26 »
misschien is je cache vol?
sudo apt-get autoremove  wil wel eens helpen

Offline Joop2

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #2 Gepost op: 2008/03/09, 19:42:40 »
Geeft helaas geen verschil
“Dream as if you'll live forever, Live as if you'll die tomorrow.”

Offline Joop2

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #3 Gepost op: 2008/03/09, 20:05:04 »
Ik heb de pakketten verwijderd met de gedachte ze opnieuw te installeren.

Ik krijg nu alleen de volgende melding:
libgnome-compiz-manager0:
 Vereisten: libwnck18 (>=2.15.90) but it is not installable
Ik kan via Synaptic libwnck18 ook niet vinden, via het Ubuntu forum kan ik hem wel downloaden.
Tijdens de installatie krijg ik deze melding: Error: Dependency is not satisfiable: libwnck-common

Ik heb Awn ook geinstalleerd, dit kan er toch niets mee te maken hebben?
“Dream as if you'll live forever, Live as if you'll die tomorrow.”

Offline siegi

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #4 Gepost op: 2008/03/09, 20:10:57 »
sudo apt-get dist-upgrade (dit zou het probleem moeten verhelpen).

Offline Joop2

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #5 Gepost op: 2008/03/09, 20:12:30 »
Dit is de melding die ik terug krijg:

root@joop-ubuntu:/home/joop# sudo apt-get dist-upgrade
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd      
Reading state information... Klaar
Opwaardering wordt doorgerekend... Klaar
0 pakketten opgewaardeerd, 0 pakketten nieuw geïnstalleerd, 0 te verwijderen en 0 niet opgewaardeerd.
“Dream as if you'll live forever, Live as if you'll die tomorrow.”

Offline siegi

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #6 Gepost op: 2008/03/09, 20:37:41 »
Dan zou compiz ondertussen toch moeten geupdate zijn ik zie geen achtergehouden pakketten meer.

Offline Joop2

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #7 Gepost op: 2008/03/09, 23:14:52 »
Nee, want ik heb Compiz verwijderd, deze melding krijg ik als ik Compiz opnieuw wil installeren..
“Dream as if you'll live forever, Live as if you'll die tomorrow.”

Offline Joop2

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #8 Gepost op: 2008/03/10, 11:06:04 »
Iemand een idee???
“Dream as if you'll live forever, Live as if you'll die tomorrow.”

Offline Johan van Dijk

  • Administrator
    • johanvandijk
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #9 Gepost op: 2008/03/10, 11:07:11 »
Wat staat er in het bestand /etc/apt/sources.list?

Offline Joop2

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #10 Gepost op: 2008/03/10, 11:23:24 »
Dit staat in /etc/apt/sources.list.save

deb cdrom:[Ubuntu 7.10 _Gutsy Gibbon_ - Release i386 (20071016)]/ gutsy main restricted
# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.

deb http://nl.archive.ubuntu.com/ubuntu/ gutsy main restricted
deb-src http://nl.archive.ubuntu.com/ubuntu/ gutsy main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://nl.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted
deb-src http://nl.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## universe WILL NOT receive any review or updates from the Ubuntu security
## team.
deb http://nl.archive.ubuntu.com/ubuntu/ gutsy universe
deb-src http://nl.archive.ubuntu.com/ubuntu/ gutsy universe
deb http://nl.archive.ubuntu.com/ubuntu/ gutsy-updates universe
deb-src http://nl.archive.ubuntu.com/ubuntu/ gutsy-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://nl.archive.ubuntu.com/ubuntu/ gutsy multiverse
deb-src http://nl.archive.ubuntu.com/ubuntu/ gutsy multiverse
deb http://nl.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse
deb-src http://nl.archive.ubuntu.com/ubuntu/ gutsy-updates multiverse

## Uncomment the following two lines to add software from the 'backports'
## repository.
## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb http://nl.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
# deb-src http://nl.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository. This software is not part of Ubuntu, but is
## offered by Canonical and the respective vendors as a service to Ubuntu
## users.
deb http://archive.canonical.com/ubuntu gutsy partner
# deb-src http://archive.canonical.com/ubuntu gutsy partner

deb http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb-src http://security.ubuntu.com/ubuntu gutsy-security main restricted
deb http://security.ubuntu.com/ubuntu gutsy-security universe
deb-src http://security.ubuntu.com/ubuntu gutsy-security universe
deb http://security.ubuntu.com/ubuntu gutsy-security multiverse
deb-src http://security.ubuntu.com/ubuntu gutsy-security multiverse
deb http://www.getautomatix.com/apt gutsy main

#AUTOMATIX REPOS START

deb http://archive.canonical.com/ubuntu gutsy partner

deb http://archive.ubuntu.com/ubuntu gutsy-backports main restricted universe multiverse
#AUTOMATIX REPOS END

deb http://packages.medibuntu.org/ gutsy free non-free
deb http://ppa.launchpad.net/reacocard-awn/ubuntu gutsy main
deb http://download.tuxfamily.org/3v1deb feisty eyecandy

Als ik /etc/apt/sources.list open krijg ik dit venster:
http://i18.photobucket.com/albums/b111/Jopio/Schermafdruk-4.png
“Dream as if you'll live forever, Live as if you'll die tomorrow.”

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #11 Gepost op: 2008/03/10, 11:32:18 »
die laatste lijn mag al weg, die is voor feisty...

bij de bovenste lijn  (cdrom) mag er ook een #  voorstaan...

voorwat hebt ge trouwens ook automatix gebruikt? die zet de backport en partner repo aan, wat eigenlijk helemaal niet nodig is...

Offline Joop2

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #12 Gepost op: 2008/03/10, 11:53:05 »
Als ik me niet vergis heb ik die gebruikt voor de installatie van m'n Gforce drivers.

Ik kheb de regels aangepast en het lijkt er op dat ik alles weer mag installeren.
Nou krijg ik Compiz alleen niet meer aan de gang.
Emerald werk weer wel, alleen mn cube doet niets.
Als ik via systeem->voorkeuren->uiterlijk->Visuele effecten->aangepast aan klik springt ie vanzelf terug op extra.
Het lijkt er dus op dat ik nog iets mis om t spulletje weer aan de gang te krijgen.

Wat hebben jullie allemaal geinstalleerd (of weet iemand wat ik mis?)
“Dream as if you'll live forever, Live as if you'll die tomorrow.”

Offline Nunslaughter

  • Lid
    • timovwb
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #13 Gepost op: 2008/03/10, 11:57:50 »
sudo apt-get install compizconfig-settings-manager

dan naar systeem=>voorkeruen=>advanced desktop effects settings


ahja, nvidia drivers worden zo geinstalleerd: systeem=>beheer=>beperkt ondersteunde stuurprogrammas...het gebruik van envy of automatix word hier afgeraden...

 en een kleine tip: ge moet uw terminal niet als root opstarten, gewoon sudo gebruiken is genoeg...

Offline siegi

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #14 Gepost op: 2008/03/10, 11:58:53 »
Installeer compizconfig-settings-manager.

En die automatix gebruik die aub niet meer daar zijn al redelijk wat problemen mee geweest. Wij ondersteunen die trouwens ook niet.

Offline Joop2

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #15 Gepost op: 2008/03/10, 12:44:33 »
compizconfig-settings-manager was al geinstalleerd.

Ik heb Automatix trouwens direct verwijderd ;)
“Dream as if you'll live forever, Live as if you'll die tomorrow.”

Offline Joop2

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #16 Gepost op: 2008/03/12, 19:32:13 »
Iemand een idee?
“Dream as if you'll live forever, Live as if you'll die tomorrow.”

Offline Ronnie

  • Lid
    • ronnie.vd.c
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #17 Gepost op: 2008/03/12, 22:46:06 »
open eens ccsm in de terminal en kijk naar de uitvoer.

doe dit ook met compiz --replace. Komt er iets vreemds uit, post de uitvoer dan hier
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Documentatie Terminal

Offline Joop2

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #18 Gepost op: 2008/03/13, 08:38:53 »
Ccsm:

joop@joop-ubuntu:~$ ccsm
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory 16x16/emotes of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory 22x22/emotes of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory 24x24/emotes of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory 32x32/emotes of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory 48x48/emotes of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory 64x64/emotes of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory 96x96/emotes of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory 128x128/emotes of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory scalable/actions of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory scalable/apps of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory scalable/categories of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory scalable/devices of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory scalable/emblems of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory scalable/emotes of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory scalable/mimetypes of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory scalable/places of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
/usr/lib/python2.5/site-packages/ccm/Utils.py:102: GtkWarning: Theme directory scalable/status of theme AER-OS-XK has no size field

  pixbuf = IconTheme.load_icon (name, size, 0)
Traceback (most recent call last):
  File "/usr/bin/ccsm", line 45, in
    idle = ccm.IdleSettingsParser(context)
  File "usr/lib/python2.5/site-packages/ccm/Utils.py", line 229, in __init__
  File "usr/lib/python2.5/site-packages/ccm/Utils.py", line 228, in
  File "usr/lib/python2.5/site-packages/ccm/Utils.py", line 225, in FilterPlugin
AttributeError: 'compizconfig.Plugin' object has no attribute 'Initialized'

compiz --replace:

joop@joop-ubuntu:~$ compiz --replace
Checking for Xgl: not present.
Detected PCI ID for VGA: 06:00.0 0300: 10de:0402 (rev a1) (prog-if 00 [VGA])
Checking for texture_from_pixmap: present.
Checking for non power of two support: present.
Checking for Composite extension: present.
Comparing resolution (1280x1024) to maximum 3D texture size (8192): Passed.
Checking for nVidia: present.
Checking for FBConfig: present.
Checking for Xgl: not present.
Starting emerald
/usr/bin/compiz.real (video) - Warn: No 8 bit GLX pixmap format, disabling YV12 image format
“Dream as if you'll live forever, Live as if you'll die tomorrow.”

Offline Ronnie

  • Lid
    • ronnie.vd.c
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #19 Gepost op: 2008/03/13, 10:40:49 »
Ben je ook blij dat Ubuntu zo toegankelijk en gratis is, en wil je graag net als ik iets terugdoen, kijk dan eens rond bij mwanzo, dé poort naar het bijdragen aan Ubuntu en haar gemeenschap!

Documentatie Terminal

Offline Joop2

  • Lid
  • Steunpunt: Nee
Kan Compiz niet updaten??
« Reactie #20 Gepost op: 2008/03/13, 20:00:47 »
Super!

Hij werkt weer.

Heb dit gedaan:


Bleek uiteindelijk heel simpel. Mijn compiz hield er mee op na een update van compiz. Blijkt dat je via de Synaptics package manager ook kunt downgraden:

synaptic package manager -> select compizconfig-settings-manager -> Menu -> Package -> Force Version dan 0.5.2 inplaats van 0.6.99. Je kunt zelfs naderhand nog een LOCK VERSION selecteren om te voorkomen dat je er elke keer gezeur over krijgt.



Nou heb ik ook een laptop met een Via VT8633 (Apollo pro 256 agp) kaart.
Ik krijg hier heel Compiz niet op aan de gang
Wel alles geinstalleerd alleen kan ik de instellingen niet van geen visuele effecten afkrijgen..
Iemand een suggestie?

Bedankt voor de moeite tot nu toe trouwens!
“Dream as if you'll live forever, Live as if you'll die tomorrow.”