Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Wake on lan configureren  (gelezen 1259 keer)

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Wake on lan configureren
« Gepost op: 2019/12/20, 16:31:42 »
Beste,

Ik heb hier een server draaiende op Ubuntu Server 18.04.3

Ik probeer hier wake on lan op te configureren maar het wel me niet lukken. Ik heb het geactiveerd met ethtool maar als ik reboot en "ethtool enp2s1" doe dan is dit men uitkomst:

Settings for enp2s1:
Supported ports: [ TP MII ]
Supported link modes:   10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Half 1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes:  10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Half 1000baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Link partner advertised link modes:  10baseT/Half 10baseT/Full
                                     100baseT/Half 100baseT/Full
                                     1000baseT/Full
Link partner advertised pause frame use: Symmetric
Link partner advertised auto-negotiation: Yes
Link partner advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Port: MII
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Cannot get wake-on-lan settings: Operation not permitted
Current message level: 0x00000033 (51)
       drv probe ifdown ifup
Link detected: yes

Blijkbaar zijn er wat gekende problemen met Realtek kaarten. Ik heb een TP Link gigabit kaart met een Realtek RTL8169 chip.

Zou iemand me wat verder kunnen helpen?

Alvast bedankt!
« Laatst bewerkt op: 2019/12/27, 20:31:15 door Jeffcoboy »
Een trotse linux-beginner!

Offline nahjo

  • Lid
  • Steunpunt: Nee
Re: Wake on lan configureren
« Reactie #1 Gepost op: 2019/12/20, 16:50:59 »
Probeer eens:
sudo ethtool enp2s1
https://help.ubuntu.com/community/WakeOnLan
« Laatst bewerkt op: 2019/12/20, 17:19:02 door nahjo »

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Re: Wake on lan configureren
« Reactie #2 Gepost op: 2019/12/27, 20:30:23 »
Ik heb ondertussen een ander moederbord geplaatst met 1 Gbps ondersteuning onboard zodat ik niet met een externe kaart zit.
Het betreft een Intel D945GCNL moederbord met de Realtek RTL8111B-GR netwerkkaart onboard dus.
Ubuntu Server 18.04.3 is opnieuw geïnstalleerd en ik heb het terug geactiveerd met ethtool.
Wake on LAN on S5 staat op "Power On" in de bios.

Zoals hier al vermeld moest ik dus inderdaad sudo gebruiken. Danku voor de tip!

Uitkomst is nu de volgende:

Settings for enp2s0:
Supported ports: [ TP ]
Supported link modes:   10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Supported FEC modes: Not reported
Advertised link modes:  10baseT/Half 10baseT/Full
                        100baseT/Half 100baseT/Full
                        1000baseT/Full
Advertised pause frame use: Symmetric Receive-only
Advertised auto-negotiation: Yes
Advertised FEC modes: Not reported
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
MDI-X: Unknown
Supports Wake-on: pumbg
Wake-on: g
Current message level: 0x00000033 (51)
       drv probe ifdown ifup
Link detected: yes

Maar nu heb ik het volgende probleem. Mijn netwerkkaart schakelt uit als ik de pc uitzet. Dus de lampjes gaan uit.
Moet ik nog iets speciaals doen om dit te voorkomen?

Alvast bedankt!
Een trotse linux-beginner!

Offline nahjo

  • Lid
  • Steunpunt: Nee
Re: Wake on lan configureren
« Reactie #3 Gepost op: 2019/12/28, 11:58:50 »
Ehh gokje,
in de BIOS WOL activeren?

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Wake on lan configureren
« Reactie #4 Gepost op: 2019/12/28, 19:24:43 »
Jeffcoboy,

Er zijn een paar dingen die belangrijk zijn met 'wakeonlan'.
Uiteraard moet op de pc die je van op afstand aan wil zetten.
In het BIOS de 'wakeonlan' aan staan.

Op de pc die je vanaf op afstand aan wilt zetten is het van belang dat elke keer bij het opstarten de 'wakeonlan' te aktiveren....
Met de opdrach uitvoerd:
sudo ethtool -s enp2s0  wol g

Of je nu deze regel in het bestand /etc/rc.local zet ...
/sbin/ethtool -s enp2s0 wol g

Of in in het bestand  /etc/network/interfaces, zie https://help.ubuntu.com/community/WakeOnLan, zet.
            up /sbin/ethtool -s enp2s0 wol g
In welk bestand je plaats, maakt niet uit, maar moet wel in EEN ervan aanwezig zijn.


Op eender welk ander pc, die je gebruikt op de ander op te starten.
Heb je 'wakeonlan' nodig.
De opdracht is:
wakeonlan <MAC_adres te starten pc>


Meestal start de bewuste pc op.
Er zijn enkele gevallen waarbij je het MAC adres moet omdraaien, vraag me niet waarom.
Dus 'wakeonlan AA:BB:CC:DD:EE:FF' wordt dan 'wakeonlan FF:EE:DD:CC:BB:AA'
In het slechte geval, wat je ook doet, zal de pc helaas niet opstarten.

MvG,
MauRice
Registered Linux user: 473556

Offline jolo

  • Lid
  • Steunpunt: Nee
Re: Wake on lan configureren
« Reactie #5 Gepost op: 2019/12/29, 10:08:44 »
Echter is die Ubuntu Wiki verouderd. Want deze werd voor het laatst in 2015 bijgewerkt. Voor Ubuntu 18.04 zijn er andere instructies. Die vond ik op deze website http://timtalbot.co.uk/setting-up-wake-on-lan-on-ubuntu-server-18-04-lts/

Ik heb deze instructies zelf met succes kunnen uittesten. Alleen deed ik dit niet met editor vim, maar met editor nano. Die is namelijk makkelijker in gebruik.
Hoofd PC januari 2018 HP Compaq Elite 8300 SFF Windows 10 & Xubuntu 18.04.3
PC 2011 Asus P8Z68-V Pro i7 2600K 8 GB RAM GT730 Testversie Xubuntu 20.04
PC 2007 Asus P5B E6600 2GB RAM 8800GTS  
Notebook 2008 Lenovo ThinkPad R61i 8932GMG 2,5 GB RAM

Offline MauRice2

  • Lid
  • Steunpunt: Nee
Re: Wake on lan configureren
« Reactie #6 Gepost op: 2019/12/29, 10:28:56 »
Echter is die Ubuntu Wiki verouderd. Want deze werd voor het laatst in 2015 bijgewerkt. Voor Ubuntu 18.04 zijn er andere instructies. Die vond ik op deze website http://timtalbot.co.uk/setting-up-wake-on-lan-on-ubuntu-server-18-04-lts/

Ik heb deze instructies zelf met succes kunnen uittesten. Alleen deed ik dit niet met editor vim, maar met editor nano. Die is namelijk makkelijker in gebruik.
Thanks Jolo,

Nog een mogelijkhied waar je de opdracht kan zetten om bij elke opstart de 'wakeonlan' te aktiveren.
En er zullen nog wel andere mogelijkheden zijn.

MvG,
MauRice
Registered Linux user: 473556

Offline nahjo

  • Lid
  • Steunpunt: Nee
Re: Wake on lan configureren
« Reactie #7 Gepost op: 2019/12/29, 15:58:53 »
Nog een tip  :)
De server/PC niet uitschakelen met de Power- Aan/Uit knop of stroom onderbreken. Dit kan de wol functie ook uitschakelen.
 

Offline Jeffcoboy

  • Lid
  • Steunpunt: Nee
Re: Wake on lan configureren
« Reactie #8 Gepost op: 2020/01/12, 13:31:56 »
Ik heb het werkend gekregen.
Blijkbaar moeten de LEDs aan de netwerkkaart zelfs niet blijven branden als de PC uit staat.
Ik had een fout gemaakt met een app waarmee ik de wake on lan wou testen. Ik deed dit enkel met IP adres, maar hij heeft ook het MAC adres nodig.

Hartelijk dank voor alle reacties!

Mvg
Een trotse linux-beginner!