Ondersteuning > Programmeren

Error bij opstarten flutter app


Error na "flutter run":
Launching lib/main.dart on Linux in debug mode...
CMake Error at /usr/share/cmake-3.22/Modules/FindPkgConfig.cmake:603 (message):
  A required package was not found
Call Stack (most recent call first):
  /usr/share/cmake-3.22/Modules/FindPkgConfig.cmake:825 (_pkg_check_modules_internal)
  flutter/CMakeLists.txt:24 (pkg_check_modules)

Output "flutter doctor -v" wat betreft Linux:
[✗] Linux toolchain - develop for Linux desktop
    • Ubuntu clang version 14.0.0-1ubuntu1
    • cmake version 3.22.1
    • ninja version 1.10.1
    • pkg-config version 0.29.2
    ✗ GTK 3.0 development libraries are required for Linux development.
      They are likely available from your distribution (e.g.: apt install libgtk-3-dev)

Installeren libgtk-3-dev levert de volgende output / error:

The following packages have unmet dependencies:
 libcairo2-dev : Depends: libfontconfig1-dev (>= 2.2.95)
                 Depends: libfreetype6-dev (>= 2.1.10)
 libgtk-3-dev : Depends: libfontconfig1-dev
 libharfbuzz-dev : Depends: libfreetype6-dev
 libpango1.0-dev : Depends: libfontconfig-dev (>= 2.13.0) but it is not installable
                   Depends: libfreetype-dev (>= 2.1.7) but it is not installable
 libxft-dev : Depends: libfontconfig1-dev
              Depends: libfreetype6-dev
E: Unable to correct problems, you have held broken packages.

Ik heb getracht individuele packages te installeren, bv.
sudo apt install libfreetype6-dev libfontconfig1-dev
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libbrotli-dev : Depends: libbrotli1 (= 1.0.9-2build6) but 1.0.9-2+ubuntu20.04.1+deb.sury.org+1 is to be installed
E: Unable to correct problems, you have held broken packages.

Probleem met libbrotli1 en libbrotli-dev krijg ik niet opgelost.

Iemand een idee of oplossing?

Het volgende command heeft het probleem opgelost:
sudo apt install libbrotli1=1.0.9-2build6


[0] Berichtenindex

Naar de volledige versie