Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: NAS in netwerk via D-Link router  (gelezen 4445 keer)

Offline force317

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
NAS in netwerk via D-Link router
« Gepost op: 2008/11/16, 10:33:19 »
Ik heb sinds zaterdag een NAS in mijn netwerk staan. Op deze NAS met vast ip adres (ingesteld op de D-Link router waaraan hij is verbonden) heb ik een share folder aangemaakt waarin verschillende folders staan met mediafiles. Vanaf de Windows XP pc's in het netwerk kan deze NAS perfekt bereikt worden en de folders in de share en hun inhoud bereikt worden.

Op mijn dual boot PC XP/Ubuntu en mijn MSI notebook Ubuntu kan ik via 'Lokaties -> Verbinden met server -> Diensttype Wndows gedeelde map' alleen maar de link naar de NAS aanmaken. Als servernaam geeft ik het vast ipadres van de NAS in, als gedeelde map de sharenaam, het veld map laat ik leeg, de gebruikersnaam voor de share is dezelfde als voor mijn aanmelden op de pc, en als domeinnaam heb ik de workgroup naam ingegeven die in de NAS is ingevuld. Of de mapnamen en workgroepnaam in hoofd- of kleine letters wordt ingegeven maakt blijkbaar niet uit. Als ik verbinden klik en het wachtwoord ingeef maakt hij een linkicoon aan op mijn bureaublad maar dat is en blijft leeg ? Is er een parameter die ik verkeerd ingeef ?

Is het de naamgeving van de subfolders op de NAS die een probleem kan zijn ? 'Mijn Video's' bvb. het ' teken ? of de aanwezigheid van spaties ? Vanaf Windows XP pc geen probleem, maar misschien wel in Ubuntu ?
Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline lizardman

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #1 Gepost op: 2008/11/16, 10:57:54 »
De aanwezigheid van spaties in de naam kan roet in het eten gooien ;-)
Als een naam een spatie bevat dan kun je dit opvangen door de naam tussen aanhalingstekens te zetten. Dus.. smb://ip.van.de.nas/"mijn muziek"

Je kunt natuurlijk ook gewoon de naam veranderen in Mijn_Muziek of zo, dus een naam zonder spaties ;-)
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline peteraerden

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #2 Gepost op: 2008/11/16, 11:03:04 »
Laat domeinnaam eens leeg,
en server gewoon het ip-adres, zonder \\ of eender, bv: 192.168.x.x

ik krijg altijd een foutmelding tussendoor, maar als ik dan ga kijken bij "Locaties"-->"Computer", dan staat deze er in.


Offline force317

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #3 Gepost op: 2008/11/17, 21:31:05 »
Ik heb nu onder meer een folder in mijn share staan met de naam Linux . Maar maakt geen verschil. Hij maakt de link naar de share aan via vast ip , maar hij is nog steeds leeg. Geen van de folders + inhoud te zien. Moet ik soms iets anders kiezen dan 'Windows gedeelde map ?'

Domeinnaam niet invullen werkt ook niet. Doet net hetzelfde als hierboven. Maakt koppeling aan in Locaties maar zonder enige inhoud.
Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline lizardman

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #4 Gepost op: 2008/11/18, 15:37:28 »
windows gedeelde map is normale samba-map dus zou goed moeten zijn.
Probeer eens in Nautilus op de adresregel: smb://ip.van.de.nas/share
Of alleen... smb://ip.van.de.nas
"Het is een teken van een ontwikkelde geest om met een gedachte te kunnen spelen zonder die te accepteren."

Aristoteles Grieks filosoof (384 v.C. - 322 v.C.)

Offline force317

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #5 Gepost op: 2008/11/18, 19:01:00 »
Euh, ik weet dat Nautilus de grafische shell van Ubuntu is, maar waar moet je die adres regel dan ingeven ?

Ik zie geen Nautilus applikatie als dusdanig die je kan opstarten ...

Niet via Locaties -> Verbinden met server ? Waar dan wel ?

Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline Gandyman

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #6 Gepost op: 2008/11/18, 21:43:04 »
Nautilus is de bestandsbeheer ..

via Locaties -> Computer
en dan op de zoekopdracht klikken.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline force317

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #7 Gepost op: 2008/11/20, 19:03:28 »
De verschillende voorgestelde methoden geprobeerd, maar niks werkt. Moet er soms iets extra geinstalleerd worden. Onder Windows XP werkt dit moeiteloos, maar onder Ubuntu ... . De aangewezen werkwijze lijkt mij via Locaties -> Verbinden met server -> Diensstype 'Windows gedeelde map' en dan vervolgens ip adres, naam gedeelde map en username opgeven. De koppeling wordt aangemaakt, ik zie zelfs het HD lampje oplichten want de NAS wordt uit de spaarstand gehaald. De koppeling wordt op het bureaublad gezet, maar ze is leeg ... .

Via smb commando's in Nautilus bereik ik helemaal niets.

Moet er soms een extra software geinstalleerd worden om een share aangemaakt met Microsoft te bereiken ?

Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline force317

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #8 Gepost op: 2008/11/20, 19:27:05 »
IK heb zojuist een aanpassing gedaan in de smb.cong file in /etc/samba. Mijn NAS en Ubuntu pc hebben nu dezelfde workgroup naam. Hierdoor worden in 'Locaties' -> 'Netwerk' nu ook de 2 sharenamen op mijn NAS voor het eerst zichtbaar ... maar spijtig genoeg geraak ik niet verder dan de sharenaam. Als ik op de sharenaam klik zegt hij dat hij de lokatie niet kan aankoppelen. Logisch, hij heeft een paswoord nodig, en daar vraagt hij niet naar.

Als ik vervolgens via 'Verbinden met server' enz. naar het ip adres van de NAS probeer te koppelen zie ik echter geen verandering. Op het bureaublad wordt de koppeling aangemaakt maar nog steeds leeg.

Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline force317

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #9 Gepost op: 2008/11/22, 11:40:35 »
Heb zojuist aangemeld met Ubuntu een nieuwe map aangemaakt (genaamd Ubuntu sharetest)op de NAS share (Locatie->Verbinden met server -> Windows gedeelde map). Dat kan zonder problemen. Als ik daarna reboot in Windows XP zie ik de map staan en kan ik er wel degelijk vanuit XP files naartoe kopiƫren. Als ik vervolgens reboot in Ubuntu en opnieuw via 'windows gedeelde map' (de enige manier die werkt), een koppeling maak zie ik alleen de koppeling ontstaan ... maar volledig leeg. Geen mappen gemaakt met XP in de share en ook de map die ik bij de vorige opstart aanmaakte in Ubuntu is niet meer te zien. Ik zit opnieuw met een lege koppeling.

Dit lijkt me eerder een probleem te zijn van permissies op mappen. In XP zie ik alle mappen, ook die gemaakt via Ubuntu, in Ubuntu zie ik alleen een lege koppeling. Iemand enig idee hoe dit kan opgelost worden ?
Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline Gandyman

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #10 Gepost op: 2008/11/23, 03:19:03 »
Citaat
Heb zojuist aangemeld met Ubuntu een nieuwe map aangemaakt (genaamd Ubuntu sharetest)op de NAS share

nu heb je weer een map gemaakt met een spatie erin ??

Kan je die map niet gewoon "test" noemen ??
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline force317

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #11 Gepost op: 2008/11/23, 10:44:25 »
Wel spaties, geen spaties, het maakt geen verschil. Heb al vanalles geprobeerd.

In lees in de handleiding van mijn NAS dat Linux om konnektie te maken NFS mapping enabled nodig heeft.
Ik moet nu een link toevoegen per Ubuntu pc aan de mapping list en dit daarna mounten in Ubuntu.
Weet iemand hierover een duidelijke uitleg staan op het internet ?
Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline force317

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #12 Gepost op: 2008/12/20, 20:07:02 »
De Ubuntu 8.10 konnektie naar mijn NAS in netwerk lukt alleen indien er een Windows XP pc verbonden aan de router waar ook de NAS en de Ubuntu pc aanhangen aangemeld staat. Dan krijg ik via Locaties -> Netwerk -> Windows netwerk netjes de NAS naam te zien naast de naam van de aangemelde Windows XP PC. Klik ik op de NAS naam krijg ik onmiddelijk mijn 2 shares op deze NAS te zien. Klik ik hierop vraagt hij het paswoord en ik kan doorgaan. Spaties in mapnamen enz zijn geen enkel probleem, alle folders en files zijn netjes te zien en bereikbaar.

Wat moet ik doen om ervoor te zorgen dat de konnektie net zo makkelijk te maken valt als er geen Widows XP Home PC aanstaat ?





Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline johan100

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #13 Gepost op: 2008/12/27, 18:25:30 »
Ook ik heb hetzelfde probleem. In Ubuntu 8.04 kon ik via Locaties - Netwerk - Windows netwerk mijn NAS niet alleen zien maar ook de bestanden benaderen. In Ubuntu 8.10 gaat dit inderdaad alleen maar als ik ook een Windows pc aanzet. Het lijkt er op dat 8.10 "iets"  mist. Nu zullen wij ongetwijfeld niet de enigen zijn die met een netwerk HD werken. Ik vraag me af hoe alle anderen dit probleem opgelost hebben.

Helpen kan ik dus niet, maar als je op een of andere manier de oplossing vindt, zet deze dan a.u.b. in dit draadje. Mocht ik via via een oplossing vinden, dan zal ik dit ook doen.


Offline force317

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #14 Gepost op: 2008/12/29, 12:34:58 »
Indien je niet de standaard 'workgroup' naam gebruikt in je netwerk maar in je router een andere naam hebt opgegeven moet je er op letten dat je in /etc/samba zoals in een hoger bericht vermeld staat deze manueel gaat aanpassen.

En dat is eigenlijk het enige dat je moet veranderen. De rest is gewoon doorklikken : Locaties -> Netwerk -> tot aan de sharenaam.

Momenteel zijn de 2 zonen natuurlijk aangemeld op hun XP pc's, maar met de komende feestdagen ga ik op een morgen eens de test doen : router aan, dan nas, tenslotte ubuntu 8.10 laptop draadloos verbinden, dit alles dus nadat alle andere pc's al uren hebben afgestaan. Eens kijken hoe de NAS dan reageert. Soms heb ik de 'indruk' dat het nadat de NAS enige tijd aanstaat wel ineens lukt. Maar dan is er vaak al eens een XP pc eventjes aangezet geweest ... . Ik heb ook de indruk dat de Ubuntu PC alleen bepaalde noodzakelijke informatie doorkrijgt als er een XP PC aktief is, of toch al na het aanzetten van de NAS aktief is geweest.

Kom ik meer te weten, dan zal ik deze informatie hier uiteraard posten.
Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline force317

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #15 Gepost op: 2008/12/31, 15:29:02 »
Ik heb gisterenmiddag de test gedaan. Eerst de router aangezet, daarna de NAS, tenslotte na een kwartiertje de MSI notebook met Ubuntu 8.10 - draadloze verbinding. En ... ik had direkt konnektie naar de NAS, zonder enig probleem, terwijl geen enkele XP pc in het netwerk aanstond. Waarom het dan soms niet werkt en dan ineens weer wel ? Ik zou het niet weten !
Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.

Offline Gandyman

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #16 Gepost op: 2008/12/31, 15:35:59 »
Je hebt misschien ooit in een ver verleden zitten rommelen met dynamische en statische ip adressen.

Loop dit dus allemaal na op alle computers en in de router.
I don't suffer from insanity, I enjoy every minute of it.
Microsoft geeft je een raam, Linux geeft je een heel huis :D

Offline force317

  • Lid
    • Bekijk profiel
  • Steunpunt: Nee
Re: NAS in netwerk via D-Link router
« Reactie #17 Gepost op: 2008/12/31, 17:13:31 »
Zou kunnen. Op dit ogenblik krijgt elk apparaat verbonden met de router een vast ip adres toegekend door de router. Maar dit was al zo op het moment dat ik een goeie maand geleden de NAS toevoegde. Ik denk niet dat het dat is. Maar ik vermoed wel dat het om de router draait. Zo kan mijn jongste zoon momenteel zijn recent gekochte PS3 niet draadloos verbinden via de router. We hadden hetzelfde probleem verleden jaar met zijn HP Vista notebook die hij aanschafte voor zijn informatika opleiding. De Vista PC zag niet eens de router, laat staan dat hij erop kon aanmelden. Totdat ik een volledige reset deed van de router en vervolgens terug alles konfigureerde. Ineens kreeg hij wel draadloos konnektie !

Daarom is de kern van dit konnektieprobleem waarschijnlijk ook weer de router. Mogelijk is dit simpelweg de beste oplossing : voeg je apparaten toe die konnektie maken met de router, doe dan eens een volledige reset en herkonfiguratie van de router.


 
Momenteel in gebruik op mijn hardware : Ubuntu 13.10, Kubuntu 13.10, Windows 7 Home, Windows 8.1 Home.