Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Koppelen Hard Disk  (gelezen 1139 keer)

Offline Martin Franssen

  • Lid
  • Steunpunt: Nee
Koppelen Hard Disk
« Gepost op: 2018/01/09, 19:02:02 »
Hallo,

Ik heb onlangs Xubuntu 16.04.3 opnieuw geïnstalleerd.
Op mijn pc heb ik een interne 2de Harde schijf, met o.a. mijn muziekbestanden.
Ik heb deze HD gekoppeld maar bij opstarten Audacious krijg ik bericht: zie bijlage 1

Voor de volledigheid nog  een afbeeldingen, van de gegevens m.b.t. het koppelpunt.

Er moet ergens iets fout zitten, want om de muziek te starten, moet ik onder “bestandsbeheer” op de map  “opslagmedium van 500mb” klikken, om vervolgens op play te klikken in audacious, waarna het probleem voor de lopende sessie is opgelost.
Na herstarten weer dezelfde procedure nodig.
Wat is de oplossing ??

















Online pederoco

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #1 Gepost op: 2018/01/09, 20:39:26 »
Misschien is het installeren van gnome-disk-utility een uitkomst.
Daarmee kun je schijven koppelen.
gnome-disk-utility is niet standaard geïnstalleerd in xubuntu.
Wil je dat?
sudo apt install gnome-disk-utilityTerug te vinden onder: Schijven

Succes!
Hiermee kan je grafisch  je schijven koppelen.

« Laatst bewerkt op: 2018/01/13, 18:51:27 door pederoco »
mvg,  Peter
Desktop: xubuntu 16.04.4 / xubuntu-minimal 18.04
Laptop: xubuntu-minimal 16.04.4 / xubuntu 18.04
"No windows in the house but somehow there's more light..."

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #2 Gepost op: 2018/01/09, 21:21:55 »
Je vermeldt: "ik heb deze schijf gekoppeld": hoe? Een schijf automatisch aankoppelen tijdens opstart doe je via een lijntje in fstab. Als je dit gedaan hebt, maar de schijf is niet gekoppeld, dan is daar nu een fout die er uit moet (zodat trouwens je schijf correct aankoppelt).

Controleer dat met het commando:
sudo mount -aIndien geen melding, dan is alvast je fstab in orde.

Aankoppelen via fstab (automatisch tijdens de opstart) kan je door een koppelpunt aan te maken:
sudo mkdir -p /data/muziek
sudo chown $USER:$USER /data/muziek
Het tweede commando maakt jezelf eigenaar van het koppelpunt zodat de partitie geheel van jou is.

Daarna meldt je de partitie aan in /etc/fstab met een extra lijn
UUID=7c9bbe...  /data/muziek ext4 defaults 0 2
Vul de correcte UUID aan. Die staat in je schermafdruk. Je kan die ook (gemakkelijker) kopieren uit de uitvoer van "sudo blkid".

Na bewaren van /etc/fstab even testen: eerst schijf ontkoppelen, dan "sudo mount -a": als hier geen melding komt, is het goed en zal je de inhoud van je partitie terugvinden onder /data/muziek.
 
« Laatst bewerkt op: 2018/01/14, 12:34:18 door vanadium »

Offline Martin Franssen

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #3 Gepost op: 2018/01/10, 00:02:43 »
Beste Peter,
Je tip opgevolgd; zonder enig merkbaar resultaat.

Beste Vanadium,
gekoppeld via terminal: sudo mount /dev/sdb1 /media/7c9bbe3b-8f49-44a4-973f-2b611c7472b2
       df -H
Resultaat: zie 2de afbeelding  1ste bericht.
sudo mount -a levert géén melding.
sudo mkdir /data/muziek  levert als reactie:  "mkdir: kan map ‘/data/muziek’ niet aanmaken: Bestand of map bestaat niet"

Dus: hoe nu  verder ??

Offline Nero

  • Lid
  • Steunpunt: Ja
Re: Koppelen Hard Disk
« Reactie #4 Gepost op: 2018/01/10, 08:20:56 »
Je map /data bestaat nog niet. Probeer eens met de -p parameter. Deze maakt de mappen recursief aan.
sudo mkdir -p /data/muziek

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #5 Gepost op: 2018/01/10, 10:25:25 »
Just, Nero, heb ik aangepast in mijn bericht.

Citaat
sudo mount -a levert géén melding.
Dan denk ik niet dat je aanpassingen gemaakt hebt in het configuratiebestand /etc/fstab. Open hiertoe fstab in een tekst editor met rootbevoegdheden

sudo -H gedit /etc/fstab
Voeg de extra lijn toe die ik aangaf. Bewaar en sluit af. Koppel de muziekpartitie eerst af en test dan met "sudo mount -a". Als er geen foutmelding is, dan is je partitie succesvol aangekoppeld onder /data/muziek

Offline Martin Franssen

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #6 Gepost op: 2018/01/10, 20:37:14 »
Hallo Nero & Vanadium,

Ik heb genoemde traject doorlopen; de HD is nu gekoppeld: gparted meldt:  "Aangekoppeld op /data/muziek" ;
Alles blijft verder hetzelfde als voorheen,
als ik audacious wil opstarten krijg ik nog steeds de mededeling: "file:///media/martin/7c9bbe3b-8f49-44a4-973f-2b611c7472b2/Muziek/", audacious blijft dus op de verkeerde plek zoeken;  of ik moet hem naar de juiste plek  toe dirigeren en dat blijft het probleem.

Dus .....?????


Offline Martin Franssen

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #7 Gepost op: 2018/01/10, 21:42:58 »
Hallo,
Ik was even vergeten hoe ik Audacious naar nieuwe map "data" moest sturen; inmiddels een aantal muziek files  opnieuw geladen, vanaf de nieuwe plek; het probleem blijft echter hetzelfde, met dien verstande dat  Audacious nu het bericht geeft:  "Fout bij het openen van file:///data/muziek/Muziek/"

Nieuwe donkere wolken aan het firmament:
Na nog wat verder zoekwerk, blijkt tot mijn stomme verbazing het volgende:
Onder bestandsbeheer was de map "opslagmedium van 500mb"  waar de muziek op staat verdwenen en waren  de muziekbestanden blijkbaar verplaatst naar de nieuwe map "data" . 
Na nog wat heen en weer gekeken te hebben (dus geen enkel ingreep gepleegd!) bleek de map map "data/muziek"  nu ineens leeg te zijn!??
Bovendien verscheen "opslagmedium van 500mb" weer onder bestandsbeheer!

Wie dit begrijpt mag het mij uitleggen!

Offline Martin Franssen

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #8 Gepost op: 2018/01/11, 10:27:45 »
Tenslotte.

Bedankt voor jullie reacties.

Blijkbaar is mijn pc gevoelig voor een goede nachtrust!
Vandaag functioneert de koppeling naar wens en is er automatisch toegang tot de HD.
Na controle, via GParted blijkt er helemaal geen koppeling meer zou zijn!?
Toch functioneert er blijkbaar een automatische koppeling.

Kortom raadsels, maar als het functioneert: "let it be"

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #9 Gepost op: 2018/01/11, 10:31:51 »
Voer het commando "mount" eens uit: daarin zal je zien dat je sdb1 aangekoppeld is onder /data/muziek.

Wat je voorheen beschreef, leek erop dat de partitie ontkoppelde. Dan zie je inderdaad alleen het lege koppelpunt. Even in de gaten houden, want dit zou op een hardwareprobleem kunnen wijzen met de hardeschijfcontroler of de harde schijf zelf. Gebeurt dat nog eens, dan zouden daarover berichten moeten verschijnen in de output van "dmesg", de kernel-log.

Offline Martin Franssen

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #10 Gepost op: 2018/01/11, 11:41:51 »
Hallo Vanadium,
Dat "let it be" was dus van zeer korte duur.
Ik krijg ook steeds meer het idee, dat het  problemen betreft in het kader dat jij aanduidt.
Onderstaand het resultaat van "mount" en "dmesg" .
Als leek zeggen deze resultaten mij helemaal niets.
Enig idee??

Resultaat “mount”
martin@Freya:~$ mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,relatime,size=1509484k,nr_inodes=377371,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=307336k,mode=755)
/dev/sda1 on / type ext4 (rw,noatime,errors=remount-ro,data=ordered)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,release_agent=/lib/systemd/systemd-cgroups-agent,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=25,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=13184)
mqueue on /dev/mqueue type mqueue (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
configfs on /sys/kernel/config type configfs (rw,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=307336k,mode=700,uid=1000,gid=1000)
gvfsd-fuse on /run/user/1000/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
martin@Freya:~$


Resultaat: “dmesg”   eerste deel van pagina 1 van in totaal 19 pagina’s

[    0.000000]   0 base 0E0000000 mask 0E0000000 uncachable
[    0.000000]   1 base 000000000 mask 000000000 write-back
[    0.000000]   2 disabled
[    0.000000]   3 disabled
[    0.000000]   4 disabled
[    0.000000]   5 disabled
[    0.000000]   6 disabled
[    0.000000]   7 disabled
[    0.000000] x86/PAT: Configuration [0-7]: WB  WC  UC- UC  WB  WC  UC- WT 
[    0.000000] total RAM covered: 3584M
[    0.000000] Found optimal setting for mtrr clean up
[    0.000000]  gran_size: 64K    chunk_size: 1G    num_reg: 2     lose cover RAM: 0G
[    0.000000] found SMP MP-table at [mem 0x000ff780-0x000ff78f] mapped at [ffff9e21000ff780]
[    0.000000] Scanning 1 areas for low memory corruption
[    0.000000] Base memory trampoline at [ffff9e2100098000] 98000 size 24576
[    0.000000] BRK [0xa8b2c000, 0xa8b2cfff] PGTABLE
[    0.000000] BRK [0xa8b2d000, 0xa8b2dfff] PGTABLE
[    0.000000] BRK [0xa8b2e000, 0xa8b2efff] PGTABLE
[    0.000000] BRK [0xa8b2f000, 0xa8b2ffff] PGTABLE
[    0.000000] BRK [0xa8b30000, 0xa8b30fff] PGTABLE
[    0.000000] BRK [0xa8b31000, 0xa8b31fff] PGTABLE
[    0.000000] BRK [0xa8b32000, 0xa8b32fff] PGTABLE
[    0.000000] RAMDISK: [mem 0x31e84000-0x34f39fff]
[    0.000000] ACPI: Early table checksum verification disabled
[    0.000000] ACPI: RSDP 0x00000000000FBDE0 000024 (v02 ACPIAM)
[    0.000000] ACPI: XSDT 0x00000000BFF90100 00005C (v01 101209 XSDT0912 20091012 MSFT 00000097)

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #11 Gepost op: 2018/01/11, 13:12:41 »
Jou pertitie komt niet (meer) voor in "mount", dus niet aangekoppeld. Voor wat dmesg betreft: je hebt het einde van die 30 blz nodig. Om het wat eenvoudiger te houden, kan je met volgend commando enkel de 30 laatste logs printen
dmesg | tail -n 30
Om alleen meer relevante uitvoer van mount te zien, doe je
mount | grep /dev/sd

Doe het volgende eens en post de output hier zodat we kunnen volgen.

- Doe eens een bestandscontrole. Hiervoor *mag* de schijf niet gekoppeld zijn.
sudo umount /dev/sdb1
sudo fsck -f /dev/sdb1
Als je schijf al ontkoppeld is, dan zal het eerste commando een waarschuwing geven. Als het tweede commando klaagt over toegang tot de partitie, dan is er vrijwel zeker een hardwareprobleem.


Offline Martin Franssen

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #12 Gepost op: 2018/01/11, 14:11:29 »
Bijgaande de resultaten van betreffende commando’s:

1.    :~$ mount | grep /dev/sd
/dev/sda1 on / type ext4 (rw,noatime,errors=remount-ro,data=ordered)

2. ~$ sudo umount /dev/sdb1
[sudo] wachtwoord voor martin:
umount: /dev/sdb1: not mounted

3. sudo fsck -f /dev/sdb1
[sudo] wachtwoord voor martin:
'fsck' uit util-linux 2.27.1
e2fsck 1.42.13 (17-May-2015)
Stap 1: Controle van inodes, blokken, en groottes
Stap 2: Controle van mappenstructuur
Stap 3: Controle van verbindingen tussen mappen
Stap 4: Controle van verwijzingsaantallen
Stap 5: Controle van groepssamenvattingen
/dev/sdb1: 27416/30531584 bestanden (12.5% niet-aaneengesloten), 48162581/122096384 blokken


Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #13 Gepost op: 2018/01/12, 11:17:00 »
Niets verkeerd te zien in die commando's. Mount eens terug met de commandolijn:
sudo mount /data/muziek
[code]
Normaal zal hier geen output zijn. De details voor de aankoppeling worden uit fstab gehaald. Indien toch foutmelding: post dan best eens je fstab hier.

Hou in de gaten of de partitie spontaan ontkoppelt of niet. Wanneer die ontkoppeld is, vraag dan eens de kernelberichten op:
[code]
dmesg | tail -n 30

Als die partitie onder dit scenario spontaan ontkoppelt, is er toch met grote zekerheid een hardwareprobleem.

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #14 Gepost op: 2018/01/12, 12:25:34 »
Dit heb ik voor een extra partitie gemaakt, dit staat dus in de fstab file.

/dev/disk/by-uuid/jouw uuid  /home/jan/gegevens/ ext4 errors=remount-ro  0  2

Ik heb een map gemaakt in de home partitie, en de rechten naar mijn gebruiker gezet.
Dus ook de gebruikte  map van jouw aanpassen.
Daarna de fstab aangepast.

Offline Martin Franssen

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #15 Gepost op: 2018/01/12, 12:31:29 »
In reactie op Jan:
Hoe fstab aanpassen (dus welk commando)?

T.a.v.  Vanadium,
onderstaande de resultaten:

1.  Inhoud: etc/fstab
via opdracht: less /etc/fstab

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda1 during installation
UUID=0d308dea-065e-414e-9eb2-ccb3c5b78567 /               ext4   noatime,errors=remount-ro 0       1
# swap was on /dev/sda5 during installation
UUID=9d93252a-1c36-4ac0-b199-7473e35466f4 none            swap    sw              0       0
#UUID=7c9bbe3b-8f49-44a4-973f-2b611c7472b2 / ext4
# UUID="7c9bbe3b-8f49-44a4-973f-2b611c7472b2" TYPE="ext4" PARTUUID="e951c25d-01"

/etc/fstab (END)

2.  sudo mount /data/muziek
[sudo] wachtwoord voor martin:
mount: can't find /data/muziek in /etc/fstab


Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #16 Gepost op: 2018/01/12, 12:39:30 »
gksudo gedit

Je fstab lijkt goed.


Heb je de map als deze niet gekoppeld is, de rechten naar je gebruiker gezet.
Dus partitie/schijf ontkoppelen, ga naar de map, maak je gebruiker eigennaar.(dit doe ik met gksudo thunar).

Dus de extra partitie/schijf moet je nog toevoegen.
Met gparted kun je de uuid uitlezen en kopieren, en in je fstab zetten.
« Laatst bewerkt op: 2018/01/12, 12:41:46 door jan11000 »

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #17 Gepost op: 2018/01/12, 13:19:46 »
In reactie op Jan:
Hoe fstab aanpassen (dus welk commando)?
Het ganse verhaal staat al vrij omstandig in mijn twee vorige berichten: ik ging ervan uit dat dat al gedaan was. Als je dit niet gedaan hebt, dan is het logisch dat /data/muziek leeg is:  er is immers niets gekoppeld. Koppel eerst eens met een commando aan vooraleer je fstab aanpast, dan zie je meteen of het zal werken.
sudo mount /dev/sdb1 /data/muziek
Terug ontkoppelen:
sudo umount /dev/sdb1
(of: "sudo umount /data/muziek")

Offline Martin Franssen

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #18 Gepost op: 2018/01/12, 18:53:20 »
Hallo,

alles netjes uitgevoerd en het functioneert; echter: na herstart is de koppeling (zoals eerder geconstateerd) verdwenen.
Betekent dat een hardwareprobleem of  mogelijk iets anders ??

Offline jan11000

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #19 Gepost op: 2018/01/13, 00:46:22 »
Laat je fstab zien, hoe deze er nu uit ziet.

Je  koppelpunt(partitie of hele schijf) moet in de fstab staan.
En de rechten van de koppel punt naar je gebruiker zetten.

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #20 Gepost op: 2018/01/13, 10:18:34 »
Wat bedoel je met "koppeling verdwenen"? Als je een icoontje in bestandsbeheer bedoelt, dan moet je weten dat dit er niet zal zijn. Als je je data kunt zien onder /data/muziek, dan is de partitie wel degelijk gekoppeld. Ook zie je dan de partitie in de uitkomst van "mount".

Zoals Jan aangeeft zal een volgende stap zijn jezelf als gebruiker rechten toe te kennen, maar dat zou het geval moeten zijn als je mijn vorige instructies volledig hebt doorgevoerd ("sudo chmod ...").

Tenslotte kan je de toegang tot die partitie vereenvoudigen door een link te plaatsen in je home folder. Dan kan je direct vanuit je homefolder naar die data. Persoonlijk zou ik hiervoor de standaard "Muziek" folder vervangen door een symbolische link naar /data/muziek. 

Offline Martin Franssen

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #21 Gepost op: 2018/01/13, 17:08:01 »
Mijn laatste poging, daarna heb ik het helemaal gehad met die koppeling, welnu:

met 'koppeling verdwenen' bedoelde ik, dat de status onder GParted aangaf:  geen koppeling.

Inmiddels aangekoppeld ; GParted geeft: aangekoppeld op /data/muziek

Via Terminal opdracht: sudo chmod /data/muziek
Resultaat: ontbrekend argument na 'data/muziek'

Geen idee wat er aan ontbreekt, u mag het zeggen

Offline koos4401

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #22 Gepost op: 2018/01/13, 17:59:41 »
chmod & andere soortgelijke commando's zijn  nogal kritisch dus: https://en.wikipedia.org/wiki/Chmod en bij voorbaat sorry voor het soort leesvoer. Google eens wat rond.
Op 27-okt-2009 om 08.20 GMT geregistreerd als gebruiker nr.: 498523

Offline Martin Franssen

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #23 Gepost op: 2018/01/14, 00:07:07 »
Na enkele uurtjes, ter controle nog eens gekeken en jawel hoor: GParted geeft aan :  "niet aangekoppeld".

Ik denk dat ik het maar op geef!!!

Offline vanadium

  • Lid
  • Steunpunt: Nee
Re: Koppelen Hard Disk
« Reactie #24 Gepost op: 2018/01/14, 12:33:13 »
Helemaal niet normaal, en volgens mij te wijten aan een falende harde schijf. Op het ogenblik dat die schijf door het systeem ontkoppeld wordt, zal er wellicht ook een systeemmelding zijn van de kernel (dmesg).

Wat betreft commando's: het moet zijn
sudo chown $USER:$USER /data/muziek
chown betekent "change owner, verander eigenaar". Daarna geef je aan welke eigenaar:groep toegewezen moet worden, in dit geval jezelf. Tenslotte geef je aan wat moet veranderd worden: de folder /data/muziek
« Laatst bewerkt op: 2018/01/14, 12:37:01 door vanadium »