Nieuws:

Welkom, Gast. Alsjeblieft inloggen of registreren.
Heb je de activerings-mail niet ontvangen?

Auteur Topic: Python: cannot import name QtGui  (gelezen 733 keer)

Offline bart85

  • Lid
  • Steunpunt: Nee
Python: cannot import name QtGui
« Gepost op: 2014/01/30, 18:44:10 »
>>> from PyQt4 import QtGui
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
ImportError: cannot import name QtGui

Waarom mist QtGui bij mij?
Ik heb net Ubuntu geherinstalleerd. Ook na de installatie kan ik QtGui niet gebruiken.
Om makkelijker te programmeren met Qt gebruik ik Monkey Studio IDE. Als ik daarin een programma wil testen krijg ik de vensters niet in beeld. Dus, denk ik dat dat ook ligt aan het ontbreken van Qtgui.
Bij de herinstallatie heb ik /home niet gewist.
Hoe kan ik dit oplossen?
« Laatst bewerkt op: 2014/01/30, 18:53:48 door bartveurink »
Als Linux niet goed genoeg vind, verander de source code.

Offline SeySayux

  • Lid
    • SeySayux.net
  • Steunpunt: Nee
Re: Python: cannot import name QtGui
« Reactie #1 Gepost op: 2014/01/30, 19:13:45 »
Heb je pyqt4-dev-tools geïnstalleerd?

PS. Wegens licentieredenen kan het misschien beter zijn als je PySide (pyside4-dev) gebruikt.
I use a Unix-based system, that means I'll get laid as often as I have to reboot.
LibSylph
SeySayux.net

Offline bart85

  • Lid
  • Steunpunt: Nee
Re: Python: cannot import name QtGui
« Reactie #2 Gepost op: 2014/01/31, 08:22:49 »
pyqt4-dev-tools heb ik niet geinstalleerd. Ben ik deze nodig?
Als Linux niet goed genoeg vind, verander de source code.

Offline SeySayux

  • Lid
    • SeySayux.net
  • Steunpunt: Nee
Re: Python: cannot import name QtGui
« Reactie #3 Gepost op: 2014/01/31, 18:11:57 »
pyqt4-dev-tools heb ik niet geinstalleerd. Ben ik deze nodig?
Ja, dit is het pakket waar PyQt4 in zit.
I use a Unix-based system, that means I'll get laid as often as I have to reboot.
LibSylph
SeySayux.net

Offline bart85

  • Lid
  • Steunpunt: Nee
Re: Python: cannot import name QtGui
« Reactie #4 Gepost op: 2014/02/01, 14:05:13 »
Daarmee is het probleem nog steeds niet verholpen.
Voordat ik python-qt4 had ge├»nstalleerd  had ik een paar andere programma's geinstalleerd. Kan het zijn dat een van deze, de oudere versie van PyQt4 gebruikt. Een onstabiele versie.
Als Linux niet goed genoeg vind, verander de source code.